cookiecutter — security advisory
The package cookiecutter before 2.1.1 are vulnerable to Command Injection via hg argument injection. When calling the cookiecutter function from Python code with the checkout parameter, it is passed to the hg checkout command in a way that additional flags can be set. The additional flags can be used to perform a command injection.
- Products
- cookiecutter
- Affected versions
- 1.7.3-3, 2.6.0-1, 2.6.0-2
- Fixed versions
- 2.6.0-1
- CVEs
- CVE-2022-24065
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:35 UTC · Revision 1
Source evidence
The package cookiecutter before 2.1.1 are vulnerable to Command Injection via hg argument injection. When calling the cookiecutter function from Python code with the checkout parameter, it is passed to the hg checkout command in a way that additional flags can be set. The additional flags can be used to perform a command injection.
osv:DEBIAN-CVE-2022-24065
cookiecutter
Fixed versions: Not specified
cookiecutter
Fixed versions: 2.6.0-1
cookiecutter
Fixed versions: 2.6.0-1
Complete source record
{
"id": "ec78c91b4199a9e475bd75fe66cb714190f9a4fe43ab28302b6e7611c95a4181",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-24065",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-24065",
"summary": "The package cookiecutter before 2.1.1 are vulnerable to Command Injection via hg argument injection. When calling the cookiecutter function from Python code with the checkout parameter, it is passed to the hg checkout command in a way that additional flags can be set. The additional flags can be used to perform a command injection.",
"evidence": "osv:DEBIAN-CVE-2022-24065",
"products": [
{
"name": {
"value": "cookiecutter",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1.7.3-3",
"evidence": "/affected/0/versions"
},
{
"value": "2.6.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.6.0-2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "cookiecutter",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.6.0-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "cookiecutter",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.6.0-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "critical",
"structured": {
"id": "DEBIAN-CVE-2022-24065",
"aliases": [
"DEBIAN-CVE-2022-24065"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "cookiecutter",
"purl": "pkg:deb/debian/cookiecutter?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1.7.3-3",
"2.6.0-1",
"2.6.0-2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-24065.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.6.0-1"
}
]
}
],
"package": {
"name": "cookiecutter",
"purl": "pkg:deb/debian/cookiecutter?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-24065.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.6.0-1"
}
]
}
],
"package": {
"name": "cookiecutter",
"purl": "pkg:deb/debian/cookiecutter?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-24065.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:00:48.137596652Z",
"provider": "osv",
"upstream": [
"CVE-2022-24065"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-24065"
]
},
"related_cves": [
{
"value": "CVE-2022-24065",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 322652,
"published_at": "2022-06-08T08:15:07.237+00:00"
}