Apache StreamPipes: Potential remote code execution (RCE) via file upload
Unrestricted Upload of File with dangerous type vulnerability in Apache StreamPipes. Such a dangerous type might be an executable file that may lead to a remote code execution (RCE). The unrestricted upload is only possible for authenticated and authorized users. This issue affects Apache StreamPipes: through 0.93.0. Users are recommended to upgrade to version 0.95.0, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-31411
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 22:35 UTC · Revision 1
Source evidence
Apache StreamPipes: Potential remote code execution (RCE) via file upload
core-osv · Original sourcePublished 17 Jul 2024, 09:22 UTC
Unrestricted Upload of File with dangerous type vulnerability in Apache StreamPipes. Such a dangerous type might be an executable file that may lead to a remote code execution (RCE). The unrestricted upload is only possible for authenticated and authorized users. This issue affects Apache StreamPipes: through 0.93.0. Users are recommended to upgrade to version 0.95.0, which fixes the issue.
osv:CVE-2024-31411
Complete source record
{
"id": "c21a778d0b5e6a0811ac94a2ff60965c051980c3a526732a90e9fc6f1b33af3e",
"url": "https://osv.dev/vulnerability/CVE-2024-31411",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache StreamPipes: Potential remote code execution (RCE) via file upload",
"summary": "Unrestricted Upload of File with dangerous type vulnerability in Apache StreamPipes. Such a dangerous type might be an executable file that may lead to a remote code execution (RCE). The unrestricted upload is only possible for authenticated and authorized users. This issue affects Apache StreamPipes: through 0.93.0. Users are recommended to upgrade to version 0.95.0, which fixes the issue.",
"evidence": "osv:CVE-2024-31411",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-31411",
"aliases": [
"CVE-2024-31411",
"GHSA-6523-jf4r-c962",
"PYSEC-2024-173"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/streampipes",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "30cbd0bee6afb63e9378b76e46b89790dc6e5e32"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:streampipes:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.95.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-31411.json"
}
}
],
"modified": "2026-10-28T02:30:23.915316606Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/31xxx/CVE-2024-31411.json",
"https://lists.apache.org/thread/b0657okbwzg5xxs11hphvc9qrd9s70mt",
"https://nvd.nist.gov/vuln/detail/CVE-2024-31411"
],
"provider_metadata": {
"cwe_ids": [
"CWE-434"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "0.93.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/31xxx/CVE-2024-31411.json"
}
},
"related_cves": [
{
"value": "CVE-2024-31411",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 490593,
"published_at": "2024-07-17T09:22:08.507+00:00"
}