MediumFix available
lemonldap-ng — security advisory
A cross-site scripting (XSS) vulnerability in LemonLDAP::NG before 2.20.1 allows remote attackers to inject arbitrary web script or HTML via the url parameter of the upgrade session confirmation page (upgradeSession / forceUpgrade) if the "Upgrade session" plugin has been enabled by an admin
- Products
- lemonldap-ng
- Affected versions
- 2.16.1+ds-2, 2.16.1+ds-deb12u1, 2.16.1+ds-deb12u2, 2.16.1+ds-deb12u3
- Fixed versions
- 2.16.1+ds-deb12u4, 2.20.1+ds-1
- CVEs
- CVE-2024-52947
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 05:16 UTC · Revision 1
Source evidence
A cross-site scripting (XSS) vulnerability in LemonLDAP::NG before 2.20.1 allows remote attackers to inject arbitrary web script or HTML via the url parameter of the upgrade session confirmation page (upgradeSession / forceUpgrade) if the "Upgrade session" plugin has been enabled by an admin
osv:DEBIAN-CVE-2024-52947
lemonldap-ng
Fixed versions: 2.16.1+ds-deb12u4
lemonldap-ng
Fixed versions: 2.20.1+ds-1
lemonldap-ng
Fixed versions: 2.20.1+ds-1
Complete source record
{
"id": "1c1a3470897d1fccaa80266be9a1ac520b5184c66b4c67b0ded217d241cc11b0",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2024-52947",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2024-52947",
"summary": "A cross-site scripting (XSS) vulnerability in LemonLDAP::NG before 2.20.1 allows remote attackers to inject arbitrary web script or HTML via the url parameter of the upgrade session confirmation page (upgradeSession / forceUpgrade) if the \"Upgrade session\" plugin has been enabled by an admin",
"evidence": "osv:DEBIAN-CVE-2024-52947",
"products": [
{
"name": {
"value": "lemonldap-ng",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.16.1+ds-deb12u4",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "2.16.1+ds-2",
"evidence": "/affected/0/versions"
},
{
"value": "2.16.1+ds-deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "2.16.1+ds-deb12u2",
"evidence": "/affected/0/versions"
},
{
"value": "2.16.1+ds-deb12u3",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "lemonldap-ng",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.20.1+ds-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "lemonldap-ng",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.20.1+ds-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2024-52947",
"aliases": [
"DEBIAN-CVE-2024-52947"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.16.1+ds-deb12u4"
}
]
}
],
"package": {
"name": "lemonldap-ng",
"purl": "pkg:deb/debian/lemonldap-ng?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"2.16.1+ds-2",
"2.16.1+ds-deb12u1",
"2.16.1+ds-deb12u2",
"2.16.1+ds-deb12u3"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2024-52947.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.20.1+ds-1"
}
]
}
],
"package": {
"name": "lemonldap-ng",
"purl": "pkg:deb/debian/lemonldap-ng?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2024-52947.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.20.1+ds-1"
}
]
}
],
"package": {
"name": "lemonldap-ng",
"purl": "pkg:deb/debian/lemonldap-ng?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2024-52947.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-18T04:00:06.061309130Z",
"provider": "osv",
"upstream": [
"CVE-2024-52947"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2024-52947"
]
},
"related_cves": [
{
"value": "CVE-2024-52947",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 366671,
"published_at": "2024-11-18T06:15:06.53+00:00"
}