ThemeMakers PayPal Express Checkout <= 1.1.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
The ThemeMakers PayPal Express Checkout plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'paypal' shortcode in versions up to, and including, 1.1.9 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-1689
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 6 Nov 2026, 04:38 UTC · Revision 1
Source evidence
ThemeMakers PayPal Express Checkout <= 1.1.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
core-osv · Original sourcePublished 27 Feb 2025, 06:48 UTC
The ThemeMakers PayPal Express Checkout plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'paypal' shortcode in versions up to, and including, 1.1.9 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
osv:CVE-2025-1689
Complete source record
{
"id": "3ba189ad2e45b2eeb164ec0b3ea597f3c3d5a9b01ca34a669a265bf573f8446b",
"url": "https://osv.dev/vulnerability/CVE-2025-1689",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "ThemeMakers PayPal Express Checkout <= 1.1.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode",
"summary": "The ThemeMakers PayPal Express Checkout plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'paypal' shortcode in versions up to, and including, 1.1.9 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
"evidence": "osv:CVE-2025-1689",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-1689",
"aliases": [
"CVE-2025-1689"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/thememakers/tmm_paypal_checkout",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "d6d3b1877ed705ac171cf7e74a6e866fc135ba22"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:thememakers:paypal_checkout:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.2.0"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "d6d3b1877ed705ac171cf7e74a6e866fc135ba22"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"cardealer_v1.1.9",
"cardealer_v1.1.8",
"cardealer_v1.1.6",
"cardealer_v1.1.5",
"v1.1.6",
"cardealer_v1.1.4",
"cardealer_v1.1.3",
"cardealer_v1.1.2",
"cardealer_v1.1.1",
"cardealer_v1.1.0",
"cardealer_v1.0.9",
"cardealer_v1.0.1",
"cardealer_v1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-1689.json"
}
}
],
"modified": "2026-10-28T02:30:46.728602465Z",
"provider": "osv",
"references": [
"https://themeforest.net/item/car-dealer-automotive-wordpress-theme-responsive/8574708",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/6390dba6-423b-48be-b5f0-1018d94f4a32?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/1xxx/CVE-2025-1689.json",
"https://nvd.nist.gov/vuln/detail/CVE-2025-1689",
"https://github.com/ThemeMakers/tmm_paypal_checkout/commit/d6d3b1877ed705ac171cf7e74a6e866fc135ba22"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "Wordfence",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/1xxx/CVE-2025-1689.json"
}
},
"related_cves": [
{
"value": "CVE-2025-1689",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 514626,
"published_at": "2025-02-27T06:48:39.544+00:00"
}