Skip to content
Heist/ feed
Back to feed
Critical

Sandbox Escape

Type: advisorySources: OSV

vm2 is a sandbox that can run untrusted code with Node's built-in modules. A sandbox escape vulnerability exists in vm2 for versions up to and including 3.9.17. It abuses an unexpected creation of a host object based on the specification of `Proxy`. As a result a threat actor can bypass the sandbox protections to gain remote code execution rights on the host running the sandbox. This vulnerability was patched in the release of version `3.9.18` of `vm2`. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2023-32314
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 19:07 UTC · Revision 1

Source evidence

Sandbox Escape

core-osv · Original source

Published 15 May 2023, 19:46 UTC

vm2 is a sandbox that can run untrusted code with Node's built-in modules. A sandbox escape vulnerability exists in vm2 for versions up to and including 3.9.17. It abuses an unexpected creation of a host object based on the specification of `Proxy`. As a result a threat actor can bypass the sandbox protections to gain remote code execution rights on the host running the sandbox. This vulnerability was patched in the release of version `3.9.18` of `vm2`. Users are advised to upgrade. There are no known workarounds for this vulnerability.

osv:CVE-2023-32314
Complete source record
{
  "id": "4ce17578f657895ed8cee1ae5981920925962e623985d64d76f0491a933ee0a9",
  "url": "https://osv.dev/vulnerability/CVE-2023-32314",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Sandbox Escape",
    "summary": "vm2 is a sandbox that can run untrusted code with Node's built-in modules. A sandbox escape vulnerability exists in vm2 for versions up to and including 3.9.17. It abuses an unexpected creation of a host object based on the specification of `Proxy`. As a result a threat actor can bypass the sandbox protections to gain remote code execution rights on the host running the sandbox. This vulnerability was patched in the release of version `3.9.18` of `vm2`. Users are advised to upgrade. There are no known workarounds for this vulnerability.",
    "evidence": "osv:CVE-2023-32314",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2023-32314",
      "aliases": [
        "CVE-2023-32314",
        "GHSA-whpj-8f3w-67p5"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/patriksimek/vm2",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2f446e5d19e6539b5164b45b1f8bd4ded4dfc085"
                },
                {
                  "fixed": "d88105f99752305c5b8a77b63ddee3ec86912daf"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:vm2_project:vm2:*:*:*:*:*:node.js:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "3.9.18"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "d88105f99752305c5b8a77b63ddee3ec86912daf"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "2f446e5d19e6539b5164b45b1f8bd4ded4dfc085"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "3.9.18"
                  }
                ]
              }
            }
          ],
          "versions": [
            "3.9.17",
            "3.9.16",
            "3.9.15",
            "3.9.14",
            "3.9.13",
            "3.9.12",
            "3.9.11",
            "3.9.10",
            "3.9.9",
            "3.9.8",
            "3.9.7",
            "3.9.6",
            "3.9.5",
            "3.9.4",
            "3.9.3",
            "v3.9.2",
            "v3.9.1",
            "v3.9.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-32314.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:51.465617990Z",
      "provider": "osv",
      "references": [
        "https://gist.github.com/arkark/e9f5cf5782dec8321095be3e52acf5ac",
        "https://github.com/patriksimek/vm2/releases/tag/3.9.18",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/32xxx/CVE-2023-32314.json",
        "https://github.com/patriksimek/vm2/security/advisories/GHSA-whpj-8f3w-67p5",
        "https://nvd.nist.gov/vuln/detail/CVE-2023-32314",
        "https://github.com/patriksimek/vm2/commit/d88105f99752305c5b8a77b63ddee3ec86912daf"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-74"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/32xxx/CVE-2023-32314.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2023-32314",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 520182,
  "published_at": "2023-05-15T19:46:32.834+00:00"
}