netty — security advisory
Netty is an asynchronous, event-driven network application framework. In versions prior to 4.1.129.Final and 4.2.8.Final, the `io.netty.handler.codec.http.HttpRequestEncoder` has a CRLF injection with the request URI when constructing a request. This leads to request smuggling when `HttpRequestEncoder` is used without proper sanitization of the URI. Any application / framework using `HttpRequestEncoder` can be subject to be abused to perform request smuggling using CRLF injection. Versions 4.1.129.Final and 4.2.8.Final fix the issue.
- Products
- netty
- Affected versions
- 1:4.1.48-10, 1:4.1.48-11, 1:4.1.48-12, 1:4.1.48-13, 1:4.1.48-14, 1:4.1.48-15, 1:4.1.48-7, 1:4.1.48-7+deb12u1
- Fixed versions
- 1:4.1.48-10+deb13u1, 1:4.1.48-16, 1:4.1.48-7+deb12u2
- CVEs
- CVE-2025-67735
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 16:16 UTC · Revision 1
Source evidence
Netty is an asynchronous, event-driven network application framework. In versions prior to 4.1.129.Final and 4.2.8.Final, the `io.netty.handler.codec.http.HttpRequestEncoder` has a CRLF injection with the request URI when constructing a request. This leads to request smuggling when `HttpRequestEncoder` is used without proper sanitization of the URI. Any application / framework using `HttpRequestEncoder` can be subject to be abused to perform request smuggling using CRLF injection. Versions 4.1.129.Final and 4.2.8.Final fix the issue.
osv:DEBIAN-CVE-2025-67735
netty
Fixed versions: 1:4.1.48-7+deb12u2
netty
Fixed versions: 1:4.1.48-10+deb13u1
netty
Fixed versions: 1:4.1.48-16
Complete source record
{
"id": "d1fe88d0eb9a0d477e1c2f254bbc7fae785304afc8be7733119e6c81344dcfe9",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2025-67735",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2025-67735",
"summary": "Netty is an asynchronous, event-driven network application framework. In versions prior to 4.1.129.Final and 4.2.8.Final, the `io.netty.handler.codec.http.HttpRequestEncoder` has a CRLF injection with the request URI when constructing a request. This leads to request smuggling when `HttpRequestEncoder` is used without proper sanitization of the URI. Any application / framework using `HttpRequestEncoder` can be subject to be abused to perform request smuggling using CRLF injection. Versions 4.1.129.Final and 4.2.8.Final fix the issue.",
"evidence": "osv:DEBIAN-CVE-2025-67735",
"products": [
{
"name": {
"value": "netty",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:4.1.48-7+deb12u2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "1:4.1.48-7",
"evidence": "/affected/0/versions"
},
{
"value": "1:4.1.48-7+deb12u1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "netty",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:4.1.48-10+deb13u1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "1:4.1.48-10",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "netty",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:4.1.48-16",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "1:4.1.48-10",
"evidence": "/affected/2/versions"
},
{
"value": "1:4.1.48-11",
"evidence": "/affected/2/versions"
},
{
"value": "1:4.1.48-12",
"evidence": "/affected/2/versions"
},
{
"value": "1:4.1.48-13",
"evidence": "/affected/2/versions"
},
{
"value": "1:4.1.48-14",
"evidence": "/affected/2/versions"
},
{
"value": "1:4.1.48-15",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2025-67735",
"aliases": [
"DEBIAN-CVE-2025-67735"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:4.1.48-7+deb12u2"
}
]
}
],
"package": {
"name": "netty",
"purl": "pkg:deb/debian/netty?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1:4.1.48-7",
"1:4.1.48-7+deb12u1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-67735.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:4.1.48-10+deb13u1"
}
]
}
],
"package": {
"name": "netty",
"purl": "pkg:deb/debian/netty?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"1:4.1.48-10"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-67735.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:4.1.48-16"
}
]
}
],
"package": {
"name": "netty",
"purl": "pkg:deb/debian/netty?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"1:4.1.48-10",
"1:4.1.48-11",
"1:4.1.48-12",
"1:4.1.48-13",
"1:4.1.48-14",
"1:4.1.48-15"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-67735.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T09:47:28.125379600Z",
"provider": "osv",
"upstream": [
"CVE-2025-67735"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2025-67735"
]
},
"related_cves": [
{
"value": "CVE-2025-67735",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 327383,
"published_at": "2025-12-16T01:15:52.367+00:00"
}