High
Weak Password Requirements in thorsten/phpmyfaq
Type: advisorySources: OSV
Weak Password Requirements in GitHub repository thorsten/phpmyfaq prior to 3.1.8.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-3754
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 09:08 UTC · Revision 1
Source evidence
Weak Password Requirements in thorsten/phpmyfaq
core-osv · Original sourcePublished 29 Oct 2022, 00:00 UTC
Weak Password Requirements in GitHub repository thorsten/phpmyfaq prior to 3.1.8.
osv:CVE-2022-3754
Complete source record
{
"id": "2027db5fd5163561647ad37e53270d02ba533490c632245c7d817398b9cd2e99",
"url": "https://osv.dev/vulnerability/CVE-2022-3754",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Weak Password Requirements in thorsten/phpmyfaq",
"summary": "Weak Password Requirements in GitHub repository thorsten/phpmyfaq prior to 3.1.8.",
"evidence": "osv:CVE-2022-3754",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2022-3754",
"aliases": [
"CVE-2022-3754",
"GHSA-2rr3-rv49-p42f"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/thorsten/phpmyfaq",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "8b47f38f2f54b90d0f160125ad3d5994883c2072"
},
{
"fixed": "d7a87d2646287828c70401ca8976ef531fbc77ea"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:phpmyfaq:phpmyfaq:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.1.8"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "d7a87d2646287828c70401ca8976ef531fbc77ea"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"3.1.7",
"3.1.6",
"3.1.5",
"3.1.4",
"3.1.3",
"3.1.2",
"3.1.1",
"3.1.0",
"3.1.0-RC",
"3.1.0-beta",
"3.1.0-alpha.3",
"3.1.0-alpha.2",
"3.1.0-alpha",
"3.0.0-beta.3",
"3.0.0-beta.2",
"3.0.0-beta",
"3.0.0-alpha.4",
"3.0.0-alpha.3",
"3.0.0-alpha.2",
"3.0.0-alpha",
"2.10.0-alpha",
"2.9.0",
"2.9.0-RC4",
"2.9.0-RC3",
"2.9.0-RC2",
"2.9.0-RC",
"2.9.0-beta2",
"2.9.0-beta",
"2.9.0-alpha4",
"2.9.0-alpha3",
"2.9.0-alpha2",
"2.9.0-alpha",
"2.8.2",
"2.8.1",
"2.8.0",
"2.8.0-RC4",
"2.8.0-RC3",
"2.8.0-RC2",
"2.8.0-RC",
"2.8.0-beta3",
"2.8.0-beta2",
"2.8.0-beta",
"2.8.0-alpha3",
"2.8.0-alpha2",
"2.7.0-RC",
"2.7.0-beta3",
"2.7.0-beta2",
"2.7.0-beta",
"2.7.0-alpha2",
"2.7.0-alpha",
"2.6.7",
"2.6.6",
"2.6.5",
"2.6.4",
"2.6.3",
"2.6.2",
"2.6.1",
"2.6.0",
"2.6.0-RC",
"2.6.0-beta",
"2.6.0-alpha"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-3754.json"
}
}
],
"modified": "2026-10-28T02:30:34.312311916Z",
"provider": "osv",
"references": [
"https://huntr.dev/bounties/f4711d7f-1368-48ab-9bef-45f32e356c47",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/3xxx/CVE-2022-3754.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-3754",
"https://github.com/thorsten/phpmyfaq/commit/d7a87d2646287828c70401ca8976ef531fbc77ea"
],
"provider_metadata": {
"cwe_ids": [
"CWE-521"
],
"cna_assigner": "@huntrdev",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/3xxx/CVE-2022-3754.json"
}
},
"related_cves": [
{
"value": "CVE-2022-3754",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 501328,
"published_at": "2022-10-29T00:00:00+00:00"
}