commons-beanutils — security advisory
Apache Commons BeanUtils, as distributed in lib/commons-beanutils-1.8.0.jar in Apache Struts 1.x through 1.3.10 and in other products requiring commons-beanutils through 1.9.2, does not suppress the class property, which allows remote attackers to "manipulate" the ClassLoader and execute arbitrary code via the class parameter, as demonstrated by the passing of this parameter to the getClass method of the ActionForm object in Struts 1.
- Products
- commons-beanutils
- Affected versions
- Not specified
- Fixed versions
- 1.9.2-1
- CVEs
- CVE-2014-0114
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 12:37 UTC · Revision 1
Source evidence
Apache Commons BeanUtils, as distributed in lib/commons-beanutils-1.8.0.jar in Apache Struts 1.x through 1.3.10 and in other products requiring commons-beanutils through 1.9.2, does not suppress the class property, which allows remote attackers to "manipulate" the ClassLoader and execute arbitrary code via the class parameter, as demonstrated by the passing of this parameter to the getClass method of the ActionForm object in Struts 1.
osv:DEBIAN-CVE-2014-0114
commons-beanutils
Fixed versions: 1.9.2-1
commons-beanutils
Fixed versions: 1.9.2-1
commons-beanutils
Fixed versions: 1.9.2-1
Complete source record
{
"id": "a83ab8c2fd179a31fcd11bde864d2e3acf546528a332645526b2dd2998cd146b",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-0114",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-0114",
"summary": "Apache Commons BeanUtils, as distributed in lib/commons-beanutils-1.8.0.jar in Apache Struts 1.x through 1.3.10 and in other products requiring commons-beanutils through 1.9.2, does not suppress the class property, which allows remote attackers to \"manipulate\" the ClassLoader and execute arbitrary code via the class parameter, as demonstrated by the passing of this parameter to the getClass method of the ActionForm object in Struts 1.",
"evidence": "osv:DEBIAN-CVE-2014-0114",
"products": [
{
"name": {
"value": "commons-beanutils",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.9.2-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "commons-beanutils",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.9.2-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "commons-beanutils",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.9.2-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2014-0114",
"aliases": [
"DEBIAN-CVE-2014-0114"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.2-1"
}
]
}
],
"package": {
"name": "commons-beanutils",
"purl": "pkg:deb/debian/commons-beanutils?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-0114.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.2-1"
}
]
}
],
"package": {
"name": "commons-beanutils",
"purl": "pkg:deb/debian/commons-beanutils?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-0114.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.2-1"
}
]
}
],
"package": {
"name": "commons-beanutils",
"purl": "pkg:deb/debian/commons-beanutils?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-0114.json"
},
"ecosystem_specific": {
"urgency": "low"
}
}
],
"modified": "2026-10-14T19:47:23.684864921Z",
"provider": "osv",
"upstream": [
"CVE-2014-0114"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-0114"
]
},
"related_cves": [
{
"value": "CVE-2014-0114",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 317553,
"published_at": "2014-04-30T10:49:03.973+00:00"
}