Skip to content
Heist/ feed
Back to feed
Critical

Apache Linkis JDBC EngineCon has a deserialization command execution

Type: advisorySources: OSV

In Apache Linkis <=1.3.1, due to the lack of effective filtering of parameters, an attacker configuring malicious Mysql JDBC parameters in JDBC EengineConn Module will trigger a deserialization vulnerability and eventually lead to remote code execution. Therefore, the parameters in the Mysql JDBC URL should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.2.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2023-29215
Confirmed fixed CVEs
Not specified
Updated in this feed
5 Nov 2026, 03:53 UTC · Revision 1

Source evidence

Apache Linkis JDBC EngineCon has a deserialization command execution

core-osv · Original source

Published 10 Apr 2023, 07:35 UTC

In Apache Linkis <=1.3.1, due to the lack of effective filtering of parameters, an attacker configuring malicious Mysql JDBC parameters in JDBC EengineConn Module will trigger a deserialization vulnerability and eventually lead to remote code execution. Therefore, the parameters in the Mysql JDBC URL should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.2.

osv:CVE-2023-29215
Complete source record
{
  "id": "54a687f2080da6a07441e5ae4824b3b7fe94deda749f3a715a99a748992f3235",
  "url": "https://osv.dev/vulnerability/CVE-2023-29215",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache Linkis JDBC EngineCon has a deserialization command execution",
    "summary": "In Apache Linkis <=1.3.1, due to the lack of effective filtering of parameters, an attacker configuring malicious Mysql JDBC parameters in JDBC EengineConn Module will trigger a deserialization vulnerability and eventually lead to remote code execution. Therefore, the parameters in the Mysql JDBC URL should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.2.",
    "evidence": "osv:CVE-2023-29215",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2023-29215",
      "aliases": [
        "CVE-2023-29215",
        "GHSA-qm2h-m799-86rc"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/linkis",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "last_affected": "8e804ff2e3c2ef55b92a206c38b6a9925f466670"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:linkis:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "last_affected": "1.3.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.3.1",
            "1.0.2",
            "1.0.1",
            "1.0.0",
            "1.0.0-RC1",
            "0.11.0",
            "0.10.0",
            "0.9.4",
            "0.9.3",
            "0.9.2",
            "0.9.1",
            "0.8.0",
            "0.7.0",
            "0.6.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-29215.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:42.066498866Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/29xxx/CVE-2023-29215.json",
        "https://lists.apache.org/thread/o682wz1ggq491ybvjwokxvcdtnzo76ls",
        "https://nvd.nist.gov/vuln/detail/CVE-2023-29215"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-502"
        ],
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "last_affected": "1.3.1"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/29xxx/CVE-2023-29215.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2023-29215",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 510027,
  "published_at": "2023-04-10T07:35:23.69+00:00"
}