Skip to content
Heist/ feed
Back to feed
High

HAX CMS NodeJs's Disabled Content Security Policy Enables Cross-Site Scripting

Type: advisorySources: OSV

HAX CMS NodeJs allows users to manage their microsite universe with a NodeJs backend. In versions 11.0.7 and below, the NodeJS version of HAX CMS has a disabled Content Security Policy (CSP). This configuration is insecure for a production application because it does not protect against cross-site-scripting attacks. The contentSecurityPolicy value is explicitly disabled in the application's Helmet configuration in app.js. This is fixed in version 11.0.8.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-54128
Confirmed fixed CVEs
Not specified
Updated in this feed
5 Nov 2026, 05:43 UTC · Revision 1

Source evidence

HAX CMS NodeJs's Disabled Content Security Policy Enables Cross-Site Scripting

core-osv · Original source

Published 21 Jul 2025, 20:46 UTC

HAX CMS NodeJs allows users to manage their microsite universe with a NodeJs backend. In versions 11.0.7 and below, the NodeJS version of HAX CMS has a disabled Content Security Policy (CSP). This configuration is insecure for a production application because it does not protect against cross-site-scripting attacks. The contentSecurityPolicy value is explicitly disabled in the application's Helmet configuration in app.js. This is fixed in version 11.0.8.

osv:CVE-2025-54128
Complete source record
{
  "id": "71e2248e25022be4b36aef7eb25fae5544415d61cc75d02e96eafdd6751a4064",
  "url": "https://osv.dev/vulnerability/CVE-2025-54128",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "HAX CMS NodeJs's Disabled Content Security Policy Enables Cross-Site Scripting",
    "summary": "HAX CMS NodeJs allows users to manage their microsite universe with a NodeJs backend. In versions 11.0.7 and below, the NodeJS version of HAX CMS has a disabled Content Security Policy (CSP). This configuration is insecure for a production application because it does not protect against cross-site-scripting attacks. The contentSecurityPolicy value is explicitly disabled in the application's Helmet configuration in app.js. This is fixed in version 11.0.8.",
    "evidence": "osv:CVE-2025-54128",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2025-54128",
      "aliases": [
        "CVE-2025-54128",
        "GHSA-59g8-h59f-8hjp"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:H/SC:L/SI:L/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/haxtheweb/haxcms-nodejs",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "3818d34c64e68f50e4bbe69278dce98669114cce"
                },
                {
                  "fixed": "ddb9351c6d6418008d4084a5b17fd6d611bc4e30"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:psu:haxcms-nodejs:*:*:*:*:*:node.js:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "11.0.8"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "ddb9351c6d6418008d4084a5b17fd6d611bc4e30"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v11.0.7",
            "v11.0.6",
            "v11.0.5",
            "v11.0.4",
            "v11.0.3",
            "v11.0.2",
            "v11.0.1",
            "v11.0.0",
            "v10.0.6",
            "v10.0.5",
            "v10.0.4",
            "v10.0.3",
            "v10.0.2",
            "v10.0.1",
            "10.0.0",
            "v9.0.21",
            "v9.0.20",
            "v9.0.19",
            "v9.0.18",
            "v9.0.17",
            "v9.0.16",
            "v9.0.15",
            "v9.0.14",
            "v9.0.13",
            "v9.0.12",
            "v9.0.11",
            "v9.0.10",
            "v9.0.9",
            "v9.0.8",
            "v9.0.7",
            "v9.0.6",
            "v9.0.5",
            "v9.0.4",
            "v9.0.3",
            "v9.0.2",
            "v9.0.1",
            "v9.0.0",
            "v9.0.0-alpha.1",
            "v9.0.0-alpha.0",
            "v0.0.19",
            "v0.0.18",
            "v0.0.17",
            "v0.0.16",
            "v0.0.15",
            "v0.0.14",
            "v0.0.13",
            "v0.0.12",
            "v0.0.11",
            "v0.0.10",
            "v0.0.9",
            "v0.0.8",
            "v0.0.7",
            "v0.0.6",
            "v0.0.5",
            "v0.0.4",
            "v0.0.3",
            "v0.0.2"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-54128.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:43.203555598Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/54xxx/CVE-2025-54128.json",
        "https://github.com/haxtheweb/issues/security/advisories/GHSA-59g8-h59f-8hjp",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-54128",
        "https://github.com/haxtheweb/haxcms-nodejs/commit/ddb9351c6d6418008d4084a5b17fd6d611bc4e30"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/54xxx/CVE-2025-54128.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-54128",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 510796,
  "published_at": "2025-07-21T20:46:31.66+00:00"
}