whisper.cpp — security advisory
A vulnerability was detected in ggml-org whisper.cpp up to 1.9.4. This affects the function whisper_model_load of the file src/whisper.cpp of the component Model Loader. Performing a manipulation of the argument ttype results in out-of-bounds read. The attack must be initiated from a local position. The exploit is now public and may be used. Upgrading to version 1.9.5 is able to mitigate this issue. The patch is named 60c0be6ac8fa71b1a2ae2dd938a31a34a508e774. It is recommended to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
- Products
- whisper.cpp
- Affected versions
- 1.7.6+dfsg-1, 1.8.2+dfsg-1, 1.8.2+dfsg-2, 1.8.2+dfsg-3, 1.8.2+dfsg-4, 1.8.2+dfsg-5, 1.8.3+dfsg-1, 1.8.3+dfsg-2, 1.8.3+dfsg-2~exp1, 1.8.3+dfsg-2~exp2, 1.8.4+dfsg-1, 1.8.6+dfsg-1, 1.8.6+dfsg-2, 1.9.1+dfsg1-1, 1.9.2+dfsg-1, 1.9.3+dfsg-1, 1.9.3+dfsg-1~exp1, 1.9.4+dfsg-1
- Fixed versions
- 1.9.5+dfsg-1
- CVEs
- CVE-2026-110810
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 20:08 UTC · Revision 1
Source evidence
A vulnerability was detected in ggml-org whisper.cpp up to 1.9.4. This affects the function whisper_model_load of the file src/whisper.cpp of the component Model Loader. Performing a manipulation of the argument ttype results in out-of-bounds read. The attack must be initiated from a local position. The exploit is now public and may be used. Upgrading to version 1.9.5 is able to mitigate this issue. The patch is named 60c0be6ac8fa71b1a2ae2dd938a31a34a508e774. It is recommended to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
osv:DEBIAN-CVE-2026-110810
whisper.cpp
Fixed versions: 1.9.5+dfsg-1
Complete source record
{
"id": "57d228c1e32e0ae6eda1ea08632f767b8bbd1c29e355ec911f3f50f72f93a400",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-110810",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-110810",
"summary": "A vulnerability was detected in ggml-org whisper.cpp up to 1.9.4. This affects the function whisper_model_load of the file src/whisper.cpp of the component Model Loader. Performing a manipulation of the argument ttype results in out-of-bounds read. The attack must be initiated from a local position. The exploit is now public and may be used. Upgrading to version 1.9.5 is able to mitigate this issue. The patch is named 60c0be6ac8fa71b1a2ae2dd938a31a34a508e774. It is recommended to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.",
"evidence": "osv:DEBIAN-CVE-2026-110810",
"products": [
{
"name": {
"value": "whisper.cpp",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.9.5+dfsg-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "1.7.6+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.2+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.2+dfsg-2",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.2+dfsg-3",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.2+dfsg-4",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.2+dfsg-5",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.3+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.3+dfsg-2",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.3+dfsg-2~exp1",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.3+dfsg-2~exp2",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.4+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.6+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.6+dfsg-2",
"evidence": "/affected/0/versions"
},
{
"value": "1.9.1+dfsg1-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.9.2+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.9.3+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.9.3+dfsg-1~exp1",
"evidence": "/affected/0/versions"
},
{
"value": "1.9.4+dfsg-1",
"evidence": "/affected/0/versions"
}
]
}
],
"severity": "low",
"structured": {
"id": "DEBIAN-CVE-2026-110810",
"aliases": [
"DEBIAN-CVE-2026-110810"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.5+dfsg-1"
}
]
}
],
"package": {
"name": "whisper.cpp",
"purl": "pkg:deb/debian/whisper.cpp?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"1.7.6+dfsg-1",
"1.8.2+dfsg-1",
"1.8.2+dfsg-2",
"1.8.2+dfsg-3",
"1.8.2+dfsg-4",
"1.8.2+dfsg-5",
"1.8.3+dfsg-1",
"1.8.3+dfsg-2",
"1.8.3+dfsg-2~exp1",
"1.8.3+dfsg-2~exp2",
"1.8.4+dfsg-1",
"1.8.6+dfsg-1",
"1.8.6+dfsg-2",
"1.9.1+dfsg1-1",
"1.9.2+dfsg-1",
"1.9.3+dfsg-1",
"1.9.3+dfsg-1~exp1",
"1.9.4+dfsg-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-110810.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-16T10:01:56.134023528Z",
"provider": "osv",
"upstream": [
"CVE-2026-110810"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-110810"
]
},
"related_cves": [
{
"value": "CVE-2026-110810",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 339066,
"published_at": "2026-10-15T01:19:27.6+00:00"
}