containerd affected by a local privilege escalation via wide permissions on CRI directory
containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths `/var/lib/containerd`, `/run/containerd/io.containerd.grpc.v1.cri` and `/run/containerd/io.containerd.sandbox.controller.v1.shim` were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administrator permissions so the host can manually chmod the directories to not have group or world accessible permissions, or to run containerd in rootless mode.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-25621
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 18:21 UTC · Revision 1
Source evidence
containerd affected by a local privilege escalation via wide permissions on CRI directory
core-osv · Original sourcePublished 6 Nov 2025, 18:36 UTC
containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths `/var/lib/containerd`, `/run/containerd/io.containerd.grpc.v1.cri` and `/run/containerd/io.containerd.sandbox.controller.v1.shim` were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administrator permissions so the host can manually chmod the directories to not have group or world accessible permissions, or to run containerd in rootless mode.
osv:CVE-2024-25621
Complete source record
{
"id": "b9a421c696bdc75ae3d3c473821084c49bddaf4d8d22168a2584e7f565327ccf",
"url": "https://osv.dev/vulnerability/CVE-2024-25621",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "containerd affected by a local privilege escalation via wide permissions on CRI directory",
"summary": "containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths `/var/lib/containerd`, `/run/containerd/io.containerd.grpc.v1.cri` and `/run/containerd/io.containerd.sandbox.controller.v1.shim` were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administrator permissions so the host can manually chmod the directories to not have group or world accessible permissions, or to run containerd in rootless mode.",
"evidence": "osv:CVE-2024-25621",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2024-25621",
"aliases": [
"CVE-2024-25621",
"GHSA-pwhc-rpq9-4c8w",
"GO-2025-4100"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/containerd/containerd",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "442cb34bda9a6a0fed82a2ca7cade05c5c749582"
},
{
"introduced": "207ad711eabd375a01713109a8a197d197ff6542"
},
{
"fixed": "4ac6c20c7bbf8177f29e46bbdc658fec02ffb8ad"
},
{
"introduced": "061792f0ecf3684fb30a3a0eb006799b8c6638a7"
},
{
"fixed": "fcd43222d6b07379a4be9786bda52438f0dd16a1"
},
{
"fixed": "7c59e8e9e970d38061a77b586b23655c352bfec5"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.7.29"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.0.7"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.1.0"
},
{
"fixed": "2.1.5"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "7c59e8e9e970d38061a77b586b23655c352bfec5"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"api/v1.10.0",
"v2.2.0-rc.1",
"v2.2.0-rc.0",
"api/v1.10.0-rc.0",
"v2.2.0-beta.2",
"v2.2.0-beta.1",
"api/v1.10.0-beta.0",
"api/v1.10.0-beta.1",
"v2.2.0-beta.0",
"v1.7.28",
"v2.1.4",
"v2.0.6",
"v2.1.3",
"v2.1.2",
"v2.1.1",
"v2.1.0",
"v2.0.5",
"v1.7.27",
"v2.0.4",
"v1.7.26",
"v2.0.3",
"v1.7.25",
"v2.0.2",
"v2.0.1",
"v1.7.24",
"v2.0.0",
"v1.7.23",
"v1.7.22",
"v1.7.21",
"v1.7.20",
"v1.7.19",
"api/v1.7.19",
"v1.7.18",
"v1.7.17",
"v1.7.16",
"v1.7.15",
"v1.7.14",
"v1.7.11",
"v1.7.13",
"v1.7.12",
"v1.7.10",
"v1.7.9",
"v1.7.8",
"v1.7.7",
"v1.7.6",
"v1.7.5",
"v1.7.4",
"v1.7.3",
"v1.7.2",
"v1.7.1",
"v1.7.0",
"v1.7.0-rc.3",
"v1.7.0-rc.2",
"v1.7.0-rc.1",
"v1.7.0-rc.0",
"v1.7.0-beta.4",
"v1.7.0-beta.3",
"v1.7.0-beta.2",
"v1.7.0-beta.1",
"v1.7.0-beta.0",
"v1.6.0-rc.3",
"v1.6.0",
"v1.6.0-rc.4",
"v1.6.0-rc.2",
"v1.6.0-rc.1",
"v1.6.0-rc.0",
"v1.6.0-beta.5",
"v1.6.0-beta.4",
"v1.6.0-beta.3",
"api/v1.6.0-beta.3",
"v1.6.0-beta.2",
"api/v1.6.0-beta.2",
"v1.6.0-beta.1",
"api/v1.6.0-beta.1",
"v1.6.0-beta.0",
"v1.5.0",
"v1.5.0-rc.3",
"v1.5.0-rc.2",
"v1.5.0-rc.1",
"v1.5.0-rc.0",
"v1.5.0-beta.4",
"v1.5.0-beta.3",
"v1.5.0-beta.2",
"v1.5.0-beta.1",
"v1.5.0-beta.0",
"v1.4.0",
"v1.4.0-rc.1",
"v1.4.0-rc.0",
"v1.4.0-beta.2",
"v1.4.0-beta.1",
"v1.4.0-beta.0",
"v1.3.0",
"v1.3.0-rc.3",
"v1.3.0-rc.2",
"v1.3.0-rc.1",
"v1.3.0-rc.0",
"v1.3.0-beta.2",
"v1.3.0-beta.1",
"v1.3.0-beta.0",
"v1.2.0",
"v1.2.0-rc.2",
"v1.2.0-rc.1",
"v1.2.0-rc.0",
"v1.2.0-beta.2",
"v1.2.0-beta.1",
"v1.2.0-beta.0",
"v1.1.0",
"v1.1.0-rc.2",
"v1.1.0-rc.1",
"v1.1.0-rc.0",
"v1.0.0",
"v1.0.0-rc.0",
"v1.0.0-beta.3",
"v1.0.0-beta.2",
"v1.0.0-beta.1",
"v1.0.0-beta.0",
"v1.0.0-alpha6",
"v1.0.0-alpha5",
"v1.0.0-alpha4",
"v1.0.0-alpha3",
"v1.0.0-alpha2",
"v1.0.0-alpha1",
"v1.0.0-alpha0",
"v0.2.0",
"0.0.5",
"0.0.4",
"0.0.3",
"0.0.2"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-25621.json"
}
}
],
"modified": "2026-10-28T02:30:44.757244054Z",
"provider": "osv",
"references": [
"https://github.com/containerd/containerd/blob/main/docs/rootless.md",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/25xxx/CVE-2024-25621.json",
"https://github.com/containerd/containerd/security/advisories/GHSA-pwhc-rpq9-4c8w",
"https://nvd.nist.gov/vuln/detail/CVE-2024-25621",
"https://github.com/containerd/containerd/commit/7c59e8e9e970d38061a77b586b23655c352bfec5"
],
"provider_metadata": {
"cwe_ids": [
"CWE-279"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/25xxx/CVE-2024-25621.json"
}
},
"related_cves": [
{
"value": "CVE-2024-25621",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 512659,
"published_at": "2025-11-06T18:36:21.566+00:00"
}