UnratedFix available
simplesamlphp — security advisory
Cross-site scripting (XSS) vulnerability in modules/core/www/no_cookie.php in SimpleSAMLphp 1.8.1 and possibly other versions before 1.8.2 allows remote attackers to inject arbitrary web script or HTML via the retryURL parameter.
- Products
- simplesamlphp
- Affected versions
- 1.6.0-1, 1.6.1-1, 1.6.2-1, 1.6.3-1, 1.6.3-2, 1.6.3-3, 1.7.0-1, 1.7.0-2, 1.8.0-1, 1.8.1-1
- Fixed versions
- 1.8.2-1
- CVEs
- CVE-2012-0040
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 22:29 UTC · Revision 1
Source evidence
Cross-site scripting (XSS) vulnerability in modules/core/www/no_cookie.php in SimpleSAMLphp 1.8.1 and possibly other versions before 1.8.2 allows remote attackers to inject arbitrary web script or HTML via the retryURL parameter.
osv:DEBIAN-CVE-2012-0040
simplesamlphp
Fixed versions: 1.8.2-1
simplesamlphp
Fixed versions: 1.8.2-1
Complete source record
{
"id": "0351feb1a3bbacf7dd4c478f4c036745440c176a65ec0ab685cffe056966050c",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2012-0040",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2012-0040",
"summary": "Cross-site scripting (XSS) vulnerability in modules/core/www/no_cookie.php in SimpleSAMLphp 1.8.1 and possibly other versions before 1.8.2 allows remote attackers to inject arbitrary web script or HTML via the retryURL parameter.",
"evidence": "osv:DEBIAN-CVE-2012-0040",
"products": [
{
"name": {
"value": "simplesamlphp",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.8.2-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "simplesamlphp",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.8.2-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "1.6.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "1.6.1-1",
"evidence": "/affected/1/versions"
},
{
"value": "1.6.2-1",
"evidence": "/affected/1/versions"
},
{
"value": "1.6.3-1",
"evidence": "/affected/1/versions"
},
{
"value": "1.6.3-2",
"evidence": "/affected/1/versions"
},
{
"value": "1.6.3-3",
"evidence": "/affected/1/versions"
},
{
"value": "1.7.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "1.7.0-2",
"evidence": "/affected/1/versions"
},
{
"value": "1.8.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "1.8.1-1",
"evidence": "/affected/1/versions"
}
]
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2012-0040",
"aliases": [
"DEBIAN-CVE-2012-0040"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.8.2-1"
}
]
}
],
"package": {
"name": "simplesamlphp",
"purl": "pkg:deb/debian/simplesamlphp?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-0040.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.8.2-1"
}
]
}
],
"package": {
"name": "simplesamlphp",
"purl": "pkg:deb/debian/simplesamlphp?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"1.6.0-1",
"1.6.1-1",
"1.6.2-1",
"1.6.3-1",
"1.6.3-2",
"1.6.3-3",
"1.7.0-1",
"1.7.0-2",
"1.8.0-1",
"1.8.1-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-0040.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T17:47:22.480477180Z",
"provider": "osv",
"upstream": [
"CVE-2012-0040"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2012-0040"
]
},
"related_cves": [
{
"value": "CVE-2012-0040",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 416587,
"published_at": "2012-01-24T18:55:01.113+00:00"
}