ruby-loofah — security advisory
Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah < 2.19.1 contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to sanitize certain SVG attributes. This may lead to a denial of service through CPU resource consumption. This issue is patched in version 2.19.1.
- Products
- ruby-loofah
- Affected versions
- Not specified
- Fixed versions
- 2.19.1-1
- CVEs
- CVE-2022-23514
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 15:00 UTC · Revision 1
Source evidence
Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah < 2.19.1 contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to sanitize certain SVG attributes. This may lead to a denial of service through CPU resource consumption. This issue is patched in version 2.19.1.
osv:DEBIAN-CVE-2022-23514
ruby-loofah
Fixed versions: 2.19.1-1
ruby-loofah
Fixed versions: 2.19.1-1
ruby-loofah
Fixed versions: 2.19.1-1
Complete source record
{
"id": "dbe5de96e9dc6e5d85f7203d990405bbd658312e4652b3f9e29319cc47944685",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-23514",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-23514",
"summary": "Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah < 2.19.1 contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to sanitize certain SVG attributes. This may lead to a denial of service through CPU resource consumption. This issue is patched in version 2.19.1.",
"evidence": "osv:DEBIAN-CVE-2022-23514",
"products": [
{
"name": {
"value": "ruby-loofah",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.19.1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby-loofah",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.19.1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby-loofah",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.19.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-23514",
"aliases": [
"DEBIAN-CVE-2022-23514"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.19.1-1"
}
]
}
],
"package": {
"name": "ruby-loofah",
"purl": "pkg:deb/debian/ruby-loofah?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23514.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.19.1-1"
}
]
}
],
"package": {
"name": "ruby-loofah",
"purl": "pkg:deb/debian/ruby-loofah?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23514.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.19.1-1"
}
]
}
],
"package": {
"name": "ruby-loofah",
"purl": "pkg:deb/debian/ruby-loofah?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23514.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:42.953177255Z",
"provider": "osv",
"upstream": [
"CVE-2022-23514"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-23514"
]
},
"related_cves": [
{
"value": "CVE-2022-23514",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 324031,
"published_at": "2022-12-14T14:15:10.477+00:00"
}