Skip to content
Heist/ feed
Back to feed
Unrated

Security advisory

Type: advisorySources: OSVCVE: CVE-2022-38153

An issue was discovered in wolfSSL before 5.5.0 (when --enable-session-ticket is used); however, only version 5.3.0 is exploitable. Man-in-the-middle attackers or a malicious server can crash TLS 1.2 clients during a handshake. If an attacker injects a large ticket (more than 256 bytes) into a NewSessionTicket message in a TLS 1.2 handshake, and the client has a non-empty session cache, the session cache frees a pointer that points to unallocated memory, causing the client to crash with a "free(): invalid pointer" message. NOTE: It is likely that this is also exploitable during TLS 1.3 handshakes between a client and a malicious server. With TLS 1.3, it is not possible to exploit this as a man-in-the-middle.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-38153
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 23:29 UTC · Revision 1

Source evidence

CVE-2022-38153

core-osv · Original source

Published 31 Aug 2022, 00:00 UTC

An issue was discovered in wolfSSL before 5.5.0 (when --enable-session-ticket is used); however, only version 5.3.0 is exploitable. Man-in-the-middle attackers or a malicious server can crash TLS 1.2 clients during a handshake. If an attacker injects a large ticket (more than 256 bytes) into a NewSessionTicket message in a TLS 1.2 handshake, and the client has a non-empty session cache, the session cache frees a pointer that points to unallocated memory, causing the client to crash with a "free(): invalid pointer" message. NOTE: It is likely that this is also exploitable during TLS 1.3 handshakes between a client and a malicious server. With TLS 1.3, it is not possible to exploit this as a man-in-the-middle.

osv:CVE-2022-38153
Complete source record
{
  "id": "30b9d1eff1c2877db2e5562cfdc7e964f105baffdb5ab654a72b29ada5ce1ddd",
  "url": "https://osv.dev/vulnerability/CVE-2022-38153",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2022-38153",
    "summary": "An issue was discovered in wolfSSL before 5.5.0 (when --enable-session-ticket is used); however, only version 5.3.0 is exploitable. Man-in-the-middle attackers or a malicious server can crash TLS 1.2 clients during a handshake. If an attacker injects a large ticket (more than 256 bytes) into a NewSessionTicket message in a TLS 1.2 handshake, and the client has a non-empty session cache, the session cache frees a pointer that points to unallocated memory, causing the client to crash with a \"free(): invalid pointer\" message. NOTE: It is likely that this is also exploitable during TLS 1.3 handshakes between a client and a malicious server. With TLS 1.3, it is not possible to exploit this as a man-in-the-middle.",
    "evidence": "osv:CVE-2022-38153",
    "products": [],
    "severity": "unknown",
    "structured": {
      "id": "CVE-2022-38153",
      "aliases": [
        "CVE-2022-38153"
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/wolfssl/wolfssl",
              "type": "GIT",
              "events": [
                {
                  "introduced": "e722c15be860794179082a05d09e6a90dc77ccf0"
                },
                {
                  "fixed": "44f81f8bc082319cebf0e37df8470aa5748c1355"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "5.5.0"
                      }
                    ],
                    "source": "DESCRIPTION"
                  },
                  {
                    "cpe": "cpe:2.3:a:wolfssl:wolfssl:5.3.0:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "5.3.0"
                      },
                      {
                        "last_affected": "5.3.0"
                      }
                    ],
                    "source": "CPE_STRING"
                  }
                ]
              }
            }
          ],
          "versions": [
            "5.3.0",
            "v5.4.0-stable",
            "v5.3.0-stable"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-38153.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:40.472073108Z",
      "provider": "osv",
      "references": [
        "https://www.wolfssl.com/docs/security-vulnerabilities/",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/38xxx/CVE-2022-38153.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-38153",
        "https://github.com/wolfSSL/wolfssl/pull/5476",
        "https://github.com/trailofbits/tlspuffin",
        "https://github.com/wolfSSL/wolfssl/releases",
        "https://blog.trailofbits.com/2023/01/12/wolfssl-vulnerabilities-tlspuffin-fuzzing-ssh/"
      ],
      "provider_metadata": {
        "cna_assigner": "mitre",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/38xxx/CVE-2022-38153.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-38153",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 507987,
  "published_at": "2022-08-31T00:00:00+00:00"
}