cacti — security advisory
Cacti is an open source operational monitoring and fault management framework. In Cacti 1.2.24, under certain conditions, an authenticated privileged user, can use a malicious string in the SNMP options of a Device, performing command injection and obtaining remote code execution on the underlying server. The `lib/snmp.php` file has a set of functions, with similar behavior, that accept in input some variables and place them into an `exec` call without a proper escape or validation. This issue has been addressed in version 1.2.25. Users are advised to upgrade. There are no known workarounds for this vulnerability.
- Products
- cacti
- Affected versions
- 1.2.24+ds1-1
- Fixed versions
- 1.2.24+ds1-1+deb12u1, 1.2.25+ds1-1
- CVEs
- CVE-2023-39362
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 16:05 UTC · Revision 1
Source evidence
Cacti is an open source operational monitoring and fault management framework. In Cacti 1.2.24, under certain conditions, an authenticated privileged user, can use a malicious string in the SNMP options of a Device, performing command injection and obtaining remote code execution on the underlying server. The `lib/snmp.php` file has a set of functions, with similar behavior, that accept in input some variables and place them into an `exec` call without a proper escape or validation. This issue has been addressed in version 1.2.25. Users are advised to upgrade. There are no known workarounds for this vulnerability.
osv:DEBIAN-CVE-2023-39362
cacti
Fixed versions: 1.2.24+ds1-1+deb12u1
cacti
Fixed versions: 1.2.25+ds1-1
cacti
Fixed versions: 1.2.25+ds1-1
Complete source record
{
"id": "ed95390cd6aa731db1ea3551500adbeeaee826f72015e590fa89ffaff81fe5ab",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-39362",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-39362",
"summary": "Cacti is an open source operational monitoring and fault management framework. In Cacti 1.2.24, under certain conditions, an authenticated privileged user, can use a malicious string in the SNMP options of a Device, performing command injection and obtaining remote code execution on the underlying server. The `lib/snmp.php` file has a set of functions, with similar behavior, that accept in input some variables and place them into an `exec` call without a proper escape or validation. This issue has been addressed in version 1.2.25. Users are advised to upgrade. There are no known workarounds for this vulnerability.",
"evidence": "osv:DEBIAN-CVE-2023-39362",
"products": [
{
"name": {
"value": "cacti",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.2.24+ds1-1+deb12u1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "1.2.24+ds1-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "cacti",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.2.25+ds1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "cacti",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.2.25+ds1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2023-39362",
"aliases": [
"DEBIAN-CVE-2023-39362"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.24+ds1-1+deb12u1"
}
]
}
],
"package": {
"name": "cacti",
"purl": "pkg:deb/debian/cacti?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1.2.24+ds1-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-39362.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.25+ds1-1"
}
]
}
],
"package": {
"name": "cacti",
"purl": "pkg:deb/debian/cacti?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-39362.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.25+ds1-1"
}
]
}
],
"package": {
"name": "cacti",
"purl": "pkg:deb/debian/cacti?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-39362.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:02:41.054323700Z",
"provider": "osv",
"upstream": [
"CVE-2023-39362"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-39362"
]
},
"related_cves": [
{
"value": "CVE-2023-39362",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 456587,
"published_at": "2023-09-05T22:15:08.817+00:00"
}