Security advisory
There is a vulnerability in Paginator (Elixir/Hex package) which makes it susceptible to Remote Code Execution (RCE) attacks via input parameters to the paginate() function. This will potentially affect all current users of Paginator prior to version 1.0.0. The vulnerability has been patched in version 1.0.0 and all users should upgrade to this version immediately. Note that this patched version uses a dependency that requires an Elixir version >=1.5.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2020-15150
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:04 UTC · Revision 1
Source evidence
There is a vulnerability in Paginator (Elixir/Hex package) which makes it susceptible to Remote Code Execution (RCE) attacks via input parameters to the paginate() function. This will potentially affect all current users of Paginator prior to version 1.0.0. The vulnerability has been patched in version 1.0.0 and all users should upgrade to this version immediately. Note that this patched version uses a dependency that requires an Elixir version >=1.5.
osv:CVE-2020-15150
Complete source record
{
"id": "f7159b5fb23336f10850240729cb1786fa326c5f1ddf36f7822e88130426c56a",
"url": "https://osv.dev/vulnerability/CVE-2020-15150",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2020-15150",
"summary": "There is a vulnerability in Paginator (Elixir/Hex package) which makes it susceptible to Remote Code Execution (RCE) attacks via input parameters to the paginate() function. This will potentially affect all current users of Paginator prior to version 1.0.0. The vulnerability has been patched in version 1.0.0 and all users should upgrade to this version immediately. Note that this patched version uses a dependency that requires an Elixir version >=1.5.",
"evidence": "osv:CVE-2020-15150",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2020-15150",
"aliases": [
"CVE-2020-15150",
"GHSA-w98m-2xqg-9cvj"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/duffelhq/paginator",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "bf45e92602e517c75aea0465efc35cd661d9ebf8"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:duffel:paginator:*:*:*:*:*:elixir:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.0.0"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "bf45e92602e517c75aea0465efc35cd661d9ebf8"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v0.6.0",
"v0.5.0",
"v0.4.0",
"v0.3.1",
"v0.3.0",
"v0.2.0",
"v0.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-15150.json"
}
}
],
"modified": "2026-10-20T10:52:47.965727590Z",
"provider": "osv",
"references": [
"https://hex.pm/packages/paginator",
"https://github.com/duffelhq/paginator/blob/ccf0f37fa96347cc8c8a7e9eb2c64462cec4b2dc/README.md#security-considerations",
"https://github.com/duffelhq/paginator/security/advisories/GHSA-w98m-2xqg-9cvj",
"https://github.com/duffelhq/paginator/commit/bf45e92602e517c75aea0465efc35cd661d9ebf8"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2020-15150",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 383835,
"published_at": "2020-09-01T17:15:11.84+00:00"
}