Skip to content
Heist/ feed
Back to feed
High

GLPI vulnerable to account takeover by authenticated user

Type: advisorySources: OSV

GLPI is a free asset and IT management software package. Starting in version 0.83 and prior to versions 9.5.13 and 10.0.7, an authenticated user can modify emails of any user, and can therefore takeover another user account through the "forgotten password" feature. By modifying emails, the user can also receive sensitive data through GLPI notifications. Versions 9.5.13 and 10.0.7 contain a patch for this issue. As a workaround, account takeover can be prevented by deactivating all notifications related to `Forgotten password?` event. However, it will not prevent unauthorized modification of any user emails.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2023-28632
Confirmed fixed CVEs
Not specified
Updated in this feed
8 Nov 2026, 00:57 UTC · Revision 1

Source evidence

GLPI vulnerable to account takeover by authenticated user

core-osv · Original source

Published 5 Apr 2023, 14:45 UTC

GLPI is a free asset and IT management software package. Starting in version 0.83 and prior to versions 9.5.13 and 10.0.7, an authenticated user can modify emails of any user, and can therefore takeover another user account through the "forgotten password" feature. By modifying emails, the user can also receive sensitive data through GLPI notifications. Versions 9.5.13 and 10.0.7 contain a patch for this issue. As a workaround, account takeover can be prevented by deactivating all notifications related to `Forgotten password?` event. However, it will not prevent unauthorized modification of any user emails.

osv:CVE-2023-28632
Complete source record
{
  "id": "6a48587320ef6d908cdaf6628f78d8e26337f8e37d4ebfcd14516cc07facd053",
  "url": "https://osv.dev/vulnerability/CVE-2023-28632",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "GLPI vulnerable to account takeover by authenticated user",
    "summary": "GLPI is a free asset and IT management software package. Starting in version 0.83 and prior to versions 9.5.13 and 10.0.7, an authenticated user can modify emails of any user, and can therefore takeover another user account through the \"forgotten password\" feature. By modifying emails, the user can also receive sensitive data through GLPI notifications. Versions 9.5.13 and 10.0.7 contain a patch for this issue. As a workaround, account takeover can be prevented by deactivating all notifications related to `Forgotten password?` event. However, it will not prevent unauthorized modification of any user emails.",
    "evidence": "osv:CVE-2023-28632",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2023-28632",
      "aliases": [
        "CVE-2023-28632",
        "GHSA-7pwm-pg76-3q9x"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/glpi-project/glpi",
              "type": "GIT",
              "events": [
                {
                  "introduced": "6e90eb69477f09e9e647eb31a05b32bad412f59e"
                },
                {
                  "fixed": "d110d2b6976208ca2cac0747cab92781b45475a7"
                },
                {
                  "introduced": "815997021a5df4feb7077a12f6f52769e9bd3459"
                },
                {
                  "fixed": "bce21331d50a020cd0928178a68fe4aac2cc50b4"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0.83"
                      },
                      {
                        "fixed": "9.5.13"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "cpe": "cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "10.0.0"
                      },
                      {
                        "fixed": "10.0.7"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "bce21331d50a020cd0928178a68fe4aac2cc50b4"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "10.0.7"
                  },
                  {
                    "range": [
                      {
                        "fixed": "d110d2b6976208ca2cac0747cab92781b45475a7"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "9.5.13"
                  }
                ]
              }
            }
          ],
          "versions": [
            "10.0.6",
            "10.0.5",
            "10.0.4",
            "10.0.3",
            "10.0.2",
            "10.0.1",
            "10.0.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-28632.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:52.505386372Z",
      "provider": "osv",
      "references": [
        "https://github.com/glpi-project/glpi/releases/tag/10.0.7",
        "https://github.com/glpi-project/glpi/releases/tag/9.5.13",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/28xxx/CVE-2023-28632.json",
        "https://github.com/glpi-project/glpi/security/advisories/GHSA-7pwm-pg76-3q9x",
        "https://nvd.nist.gov/vuln/detail/CVE-2023-28632"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-269"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/28xxx/CVE-2023-28632.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2023-28632",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 521146,
  "published_at": "2023-04-05T14:45:12.075+00:00"
}