Security advisory
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was found in Exiv2 versions v0.27.3 and earlier. The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as insert. The bug is fixed in version v0.27.4.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-29470
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 10:18 UTC · Revision 1
Source evidence
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was found in Exiv2 versions v0.27.3 and earlier. The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as insert. The bug is fixed in version v0.27.4.
osv:CVE-2021-29470
Complete source record
{
"id": "b14de7db7d1882a41c449729a91cf75f241304a30f85e85dca99d460b276680d",
"url": "https://osv.dev/vulnerability/CVE-2021-29470",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-29470",
"summary": "Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was found in Exiv2 versions v0.27.3 and earlier. The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as insert. The bug is fixed in version v0.27.4.",
"evidence": "osv:CVE-2021-29470",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2021-29470",
"aliases": [
"CVE-2021-29470",
"GHSA-8949-hhfh-j7rj"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/exiv2/exiv2",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"last_affected": "194bb65ac568a5435874c9d9d73b1c8a68e4edec"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:exiv2:exiv2:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"last_affected": "0.27.3"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v0.27.3",
"v0.27.3-RC2",
"v0.27.3-RC1",
"v0.27.2",
"v0.27.2-RC3",
"v0.27.2-RC2",
"v0.27.2-RC1",
"0.27-RC2",
"v0.27.1",
"0.27.1",
"v0.27.1-RC1",
"v0.27.0",
"0.27",
"0.27-RC3",
"v0.27-RC1",
"v0.26",
"v0.25",
"v0.24",
"v0.23.1",
"v0.23",
"v0.22",
"v0.21.1",
"v0.21",
"v0.20",
"v0.19",
"v0.18.2",
"v0.18.1",
"v0.18",
"v0.18-pre2",
"v0.18-pre1",
"v0.17.1",
"v0.17",
"v0.16",
"v0.16-pre1",
"v0.15",
"v0.14",
"v0.13",
"v0.12",
"v0.11",
"v0.10",
"v0.9.1",
"v0.9",
"v0.8",
"v0.7",
"v0.6.2",
"v0.6.1",
"v0.6",
"v0.5",
"v0.4",
"v0.3"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-29470.json"
}
}
],
"modified": "2026-10-20T10:50:07.990408726Z",
"provider": "osv",
"references": [
"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2XQT5F5IINTDYDAFGVGQZ7PMMLG7I5ZZ/",
"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JWZLDECIXXW3CCZ3RS4A3NG5X5VE4WZM/",
"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LBKWLTXM7IKZ4PVGKLUQVAVFAYGGF7QR/",
"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/P2A5GMJEXQ5Q76JK6F6VKK5JYCLVFGKN/",
"https://security.gentoo.org/glsa/202312-06",
"https://github.com/Exiv2/exiv2/pull/1581",
"https://github.com/Exiv2/exiv2/security/advisories/GHSA-8949-hhfh-j7rj"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:*",
"cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:*"
],
"vendor_product": "fedoraproject:fedora",
"extracted_events": [
{
"range": [
{
"introduced": "33"
},
{
"last_affected": "33"
},
{
"introduced": "34"
},
{
"last_affected": "34"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2021-29470",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 381322,
"published_at": "2021-04-23T19:15:11.243+00:00"
}