Medium
Security advisory
The Nextcloud dialogs library (npm package @nextcloud/dialogs) before 3.1.2 insufficiently escaped text input passed to a toast. If your application displays toasts with user-supplied input, this could lead to a XSS vulnerability. The vulnerability has been patched in version 3.1.2 If you need to display HTML in the toast, explicitly pass the `options.isHTML` config flag.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-29438
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:16 UTC · Revision 1
Source evidence
The Nextcloud dialogs library (npm package @nextcloud/dialogs) before 3.1.2 insufficiently escaped text input passed to a toast. If your application displays toasts with user-supplied input, this could lead to a XSS vulnerability. The vulnerability has been patched in version 3.1.2 If you need to display HTML in the toast, explicitly pass the `options.isHTML` config flag.
osv:CVE-2021-29438
Complete source record
{
"id": "97a11f4fe720f30c4483f30cc01905bd08cae5ff8d685e9b4d5759e7f2b2359d",
"url": "https://osv.dev/vulnerability/CVE-2021-29438",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-29438",
"summary": "The Nextcloud dialogs library (npm package @nextcloud/dialogs) before 3.1.2 insufficiently escaped text input passed to a toast. If your application displays toasts with user-supplied input, this could lead to a XSS vulnerability. The vulnerability has been patched in version 3.1.2 If you need to display HTML in the toast, explicitly pass the `options.isHTML` config flag.",
"evidence": "osv:CVE-2021-29438",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2021-29438",
"aliases": [
"CVE-2021-29438",
"GHSA-g3fq-3v3g-mh32"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/nextcloud-libraries/nextcloud-dialogs",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "9e4acefa165177c40204aff768e24bcc4b4a6aec"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:nextcloud\\/dialogs_project:nextcloud\\/dialogs:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.1.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.0.1",
"v2.0.0",
"v1.4.0",
"v1.3.1",
"v1.3.0",
"v1.2.2",
"v1.2.1",
"v1.2.0",
"v1.1.0",
"v1.0.0",
"v0.1.1",
"v0.1.0",
"v0.0.3",
"v0.0.2",
"v0.0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-29438.json"
}
}
],
"modified": "2026-10-20T10:53:45.372036847Z",
"provider": "osv",
"references": [
"https://www.npmjs.com/package/%40nextcloud/dialogs",
"https://github.com/nextcloud/nextcloud-dialogs/security/advisories/GHSA-g3fq-3v3g-mh32"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-29438",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 384582,
"published_at": "2021-04-13T20:15:22.187+00:00"
}