Low
Apache APISIX: Cas-auth plugin open redirect via unsanitized cookie value
Type: advisorySources: OSV
URL Redirection to Untrusted Site ('Open Redirect') vulnerability in Apache APISIX. The default configuration of cas-auth in Apache APISIX is vulnerable to phishing and credential theft. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-44915
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 04:09 UTC · Revision 1
Source evidence
Apache APISIX: Cas-auth plugin open redirect via unsanitized cookie value
core-osv · Original sourcePublished 19 Jun 2026, 13:12 UTC
URL Redirection to Untrusted Site ('Open Redirect') vulnerability in Apache APISIX. The default configuration of cas-auth in Apache APISIX is vulnerable to phishing and credential theft. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
osv:CVE-2026-44915
Complete source record
{
"id": "23d9153b865f54951806d266bd2f4ac70ac738b535d22355ed7fd686e68c96d9",
"url": "https://osv.dev/vulnerability/CVE-2026-44915",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache APISIX: Cas-auth plugin open redirect via unsanitized cookie value",
"summary": "URL Redirection to Untrusted Site ('Open Redirect') vulnerability in Apache APISIX. The default configuration of cas-auth in Apache APISIX is vulnerable to phishing and credential theft. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.",
"evidence": "osv:CVE-2026-44915",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2026-44915",
"aliases": [
"BIT-apisix-2026-44915",
"CVE-2026-44915"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/apisix",
"type": "GIT",
"events": [
{
"introduced": "24d1ec762e4bee402cc98b5ca57a08531f3c0b51"
},
{
"fixed": "9ef2ecab67f652d38365049613610ef649bb4ad0"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.17.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-44915.json"
}
}
],
"modified": "2026-10-28T02:30:42.393682170Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/44xxx/CVE-2026-44915.json",
"https://lists.apache.org/thread/2syk2kkzjnpzrdh98plbzj8os7wn521c",
"https://nvd.nist.gov/vuln/detail/CVE-2026-44915"
],
"provider_metadata": {
"cwe_ids": [
"CWE-601"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "3.0.0"
},
{
"last_affected": "3.16.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/44xxx/CVE-2026-44915.json"
}
},
"related_cves": [
{
"value": "CVE-2026-44915",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 510165,
"published_at": "2026-06-19T13:12:33.435+00:00"
}