Security advisory
In modules/HELPBOT_MODULE in Budabot 0.6 through 4.0, lax syntax validation allows remote attackers to perform a command injection attack against the PHP daemon with a crafted command, resulting in a denial of service or possibly unspecified other impact, as demonstrated by the "!calc 5 x 5" command. In versions before 3.0, modules/HELPBOT_MODULE/calc.php has the vulnerable code; in 3.0 and above, modules/HELPBOT_MODULE/HelpbotController.class.php has the vulnerable code.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-19290
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 04:18 UTC · Revision 1
Source evidence
In modules/HELPBOT_MODULE in Budabot 0.6 through 4.0, lax syntax validation allows remote attackers to perform a command injection attack against the PHP daemon with a crafted command, resulting in a denial of service or possibly unspecified other impact, as demonstrated by the "!calc 5 x 5" command. In versions before 3.0, modules/HELPBOT_MODULE/calc.php has the vulnerable code; in 3.0 and above, modules/HELPBOT_MODULE/HelpbotController.class.php has the vulnerable code.
osv:CVE-2018-19290
Complete source record
{
"id": "1bd1624a74c3c6b4285cbb7eee75da2d999e048792965c8daa8b7272153750fa",
"url": "https://osv.dev/vulnerability/CVE-2018-19290",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-19290",
"summary": "In modules/HELPBOT_MODULE in Budabot 0.6 through 4.0, lax syntax validation allows remote attackers to perform a command injection attack against the PHP daemon with a crafted command, resulting in a denial of service or possibly unspecified other impact, as demonstrated by the \"!calc 5 x 5\" command. In versions before 3.0, modules/HELPBOT_MODULE/calc.php has the vulnerable code; in 3.0 and above, modules/HELPBOT_MODULE/HelpbotController.class.php has the vulnerable code.",
"evidence": "osv:CVE-2018-19290",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2018-19290",
"aliases": [
"CVE-2018-19290"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/budabot/budabot",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "28e6d947574f8cc9914746274e6183df07a258d7"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "3.0"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"versions": [
"3.0_RC5",
"3.0_RC4"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-19290.json"
}
}
],
"modified": "2026-10-24T10:30:16.992393557Z",
"provider": "osv",
"references": [],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:a:budabot:budabot:*:*:*:*:*:*:*:*"
],
"vendor_product": "budabot:budabot",
"extracted_events": [
{
"range": [
{
"introduced": "0.6"
},
{
"last_affected": "4.0"
}
],
"source": "CPE_RANGE"
}
]
},
{
"extracted_events": [
{
"range": [
{
"introduced": "0.6"
},
{
"last_affected": "4.0"
}
],
"source": "DESCRIPTION"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2018-19290",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 429461,
"published_at": "2018-11-30T18:29:00.567+00:00"
}