caddy — security advisory
Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, Caddy’s stripHTML template function cannot reliably remove all HTML tags from input strings. Certain malformed HTML, such as <<>img src=x onerror=alert()>, can bypass the tag-stripping logic, potentially leaving dangerous content in the output if it is later rendered as HTML. This may allow client-side XSS in cases where untrusted strings are rendered unsafely. This vulnerability is fixed in 2.11.4.
- Products
- caddy
- Affected versions
- 2.11.4-1, 2.6.2-11, 2.6.2-12, 2.6.2-14, 2.6.2-14ubuntu0.26.04.1~esm1, 2.6.2-6, 2.6.2-6ubuntu0.24.04.1, 2.6.2-6ubuntu0.24.04.2, 2.6.2-6ubuntu0.24.04.2+esm1, 2.6.2-6ubuntu0.24.04.3, 2.6.2-6ubuntu0.24.04.3+esm1, 2.6.2-6ubuntu0.24.04.3+esm2, 2.6.2-9
- Fixed versions
- Not specified
- CVEs
- CVE-2026-52846
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 03:08 UTC · Revision 1
Source evidence
Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, Caddy’s stripHTML template function cannot reliably remove all HTML tags from input strings. Certain malformed HTML, such as <<>img src=x onerror=alert()>, can bypass the tag-stripping logic, potentially leaving dangerous content in the output if it is later rendered as HTML. This may allow client-side XSS in cases where untrusted strings are rendered unsafely. This vulnerability is fixed in 2.11.4.
osv:UBUNTU-CVE-2026-52846
caddy
Fixed versions: Not specified
caddy
Fixed versions: Not specified
caddy
Fixed versions: Not specified
caddy
Fixed versions: Not specified
Complete source record
{
"id": "235ad3a454738b5e06384f406732cb3a767a25a5943f371618da17b67991ae4b",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2026-52846",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2026-52846",
"summary": "Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, Caddy’s stripHTML template function cannot reliably remove all HTML tags from input strings. Certain malformed HTML, such as <<>img src=x onerror=alert()>, can bypass the tag-stripping logic, potentially leaving dangerous content in the output if it is later rendered as HTML. This may allow client-side XSS in cases where untrusted strings are rendered unsafely. This vulnerability is fixed in 2.11.4.",
"evidence": "osv:UBUNTU-CVE-2026-52846",
"products": [
{
"name": {
"value": "caddy",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.6.2-6",
"evidence": "/affected/0/versions"
},
{
"value": "2.6.2-6ubuntu0.24.04.1",
"evidence": "/affected/0/versions"
},
{
"value": "2.6.2-6ubuntu0.24.04.2",
"evidence": "/affected/0/versions"
},
{
"value": "2.6.2-6ubuntu0.24.04.2+esm1",
"evidence": "/affected/0/versions"
},
{
"value": "2.6.2-6ubuntu0.24.04.3",
"evidence": "/affected/0/versions"
},
{
"value": "2.6.2-6ubuntu0.24.04.3+esm1",
"evidence": "/affected/0/versions"
},
{
"value": "2.6.2-6ubuntu0.24.04.3+esm2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "caddy",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.6.2-9",
"evidence": "/affected/1/versions"
},
{
"value": "2.6.2-11",
"evidence": "/affected/1/versions"
},
{
"value": "2.6.2-12",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "caddy",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.6.2-14",
"evidence": "/affected/2/versions"
},
{
"value": "2.11.4-1",
"evidence": "/affected/2/versions"
}
]
},
{
"name": {
"value": "caddy",
"evidence": "/affected/3/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.6.2-12",
"evidence": "/affected/3/versions"
},
{
"value": "2.6.2-14",
"evidence": "/affected/3/versions"
},
{
"value": "2.6.2-14ubuntu0.26.04.1~esm1",
"evidence": "/affected/3/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "UBUNTU-CVE-2026-52846",
"aliases": [
"UBUNTU-CVE-2026-52846"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "caddy",
"purl": "pkg:deb/ubuntu/caddy?arch=source&distro=esm-apps%2Fnoble",
"ecosystem": "Ubuntu:Pro:24.04:LTS"
},
"versions": [
"2.6.2-6",
"2.6.2-6ubuntu0.24.04.1",
"2.6.2-6ubuntu0.24.04.2",
"2.6.2-6ubuntu0.24.04.2+esm1",
"2.6.2-6ubuntu0.24.04.3",
"2.6.2-6ubuntu0.24.04.3+esm1",
"2.6.2-6ubuntu0.24.04.3+esm2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-52846.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "caddy",
"binary_version": "2.6.2-6ubuntu0.24.04.3+esm2"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "caddy",
"purl": "pkg:deb/ubuntu/caddy?arch=source&distro=questing",
"ecosystem": "Ubuntu:25.10"
},
"versions": [
"2.6.2-9",
"2.6.2-11",
"2.6.2-12"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-52846.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "caddy",
"binary_version": "2.6.2-12"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "caddy",
"purl": "pkg:deb/ubuntu/caddy?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"2.6.2-14",
"2.11.4-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-52846.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "caddy",
"binary_version": "2.11.4-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "caddy",
"purl": "pkg:deb/ubuntu/caddy?arch=source&distro=esm-apps%2Fresolute",
"ecosystem": "Ubuntu:Pro:26.04:LTS"
},
"versions": [
"2.6.2-12",
"2.6.2-14",
"2.6.2-14ubuntu0.26.04.1~esm1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-52846.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "caddy",
"binary_version": "2.6.2-14ubuntu0.26.04.1~esm1"
}
]
}
}
],
"modified": "2026-10-17T13:00:24.629918901Z",
"provider": "osv",
"upstream": [
"CVE-2026-52846"
],
"references": [
"https://ubuntu.com/security/CVE-2026-52846",
"https://www.cve.org/CVERecord?id=CVE-2026-52846"
]
},
"related_cves": [
{
"value": "CVE-2026-52846",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 360507,
"published_at": "2026-06-23T18:18:00+00:00"
}