Skip to content
Heist/ feed
Back to feed
UnratedFix available

apt — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2012-0214

The pkgAcqMetaClearSig::Failed method in apt-pkg/acquire-item.cc in Advanced Package Tool (APT) 0.8.11 through 0.8.15.10 and 0.8.16 before 0.8.16~exp13, when updating from repositories that use InRelease files, allows man-in-the-middle attackers to install arbitrary packages by preventing a user from downloading the new InRelease file, which leaves the original InRelease file active and makes it more difficult to detect that the Packages file is modified and unsigned.

Products
apt
Affected versions
Not specified
Fixed versions
0.8.15.10
CVEs
CVE-2012-0214
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 23:09 UTC · Revision 1

Source evidence

DEBIAN-CVE-2012-0214

core-osv · Original source

Published 15 Apr 2014, 23:55 UTC

The pkgAcqMetaClearSig::Failed method in apt-pkg/acquire-item.cc in Advanced Package Tool (APT) 0.8.11 through 0.8.15.10 and 0.8.16 before 0.8.16~exp13, when updating from repositories that use InRelease files, allows man-in-the-middle attackers to install arbitrary packages by preventing a user from downloading the new InRelease file, which leaves the original InRelease file active and makes it more difficult to detect that the Packages file is modified and unsigned.

osv:DEBIAN-CVE-2012-0214

apt

Fixed versions: 0.8.15.10

apt

Fixed versions: 0.8.15.10

apt

Fixed versions: 0.8.15.10

Complete source record
{
  "id": "82ba6df25fcc674c5caa3f35dae1e3dc0e62e5147981286deae3898bb0f12903",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2012-0214",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2012-0214",
    "summary": "The pkgAcqMetaClearSig::Failed method in apt-pkg/acquire-item.cc in Advanced Package Tool (APT) 0.8.11 through 0.8.15.10 and 0.8.16 before 0.8.16~exp13, when updating from repositories that use InRelease files, allows man-in-the-middle attackers to install arbitrary packages by preventing a user from downloading the new InRelease file, which leaves the original InRelease file active and makes it more difficult to detect that the Packages file is modified and unsigned.",
    "evidence": "osv:DEBIAN-CVE-2012-0214",
    "products": [
      {
        "name": {
          "value": "apt",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.8.15.10",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "apt",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.8.15.10",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "apt",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.8.15.10",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "unknown",
    "structured": {
      "id": "DEBIAN-CVE-2012-0214",
      "aliases": [
        "DEBIAN-CVE-2012-0214"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.8.15.10"
                }
              ]
            }
          ],
          "package": {
            "name": "apt",
            "purl": "pkg:deb/debian/apt?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-0214.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.8.15.10"
                }
              ]
            }
          ],
          "package": {
            "name": "apt",
            "purl": "pkg:deb/debian/apt?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-0214.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.8.15.10"
                }
              ]
            }
          ],
          "package": {
            "name": "apt",
            "purl": "pkg:deb/debian/apt?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-0214.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T17:47:36.330514859Z",
      "provider": "osv",
      "upstream": [
        "CVE-2012-0214"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2012-0214"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2012-0214",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 417888,
  "published_at": "2014-04-15T23:55:08.313+00:00"
}