Type confusion in AWS pgcollection allows remote code execution
pgcollection is an open source extension to PostgreSQL. A type confusion issue in AWS pgcollection 2.0.0 through 2.1.1 might allow an authenticated remote user to execute arbitrary code as the postgres operating system user via crafted SQL statements that rely on mismatched type metadata in collection value retrieval and array conversion functions. To remediate this issue, users should upgrade to version 2.1.2 or later.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-96883
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 02:53 UTC · Revision 1
Source evidence
Type confusion in AWS pgcollection allows remote code execution
core-osv · Original sourcePublished 24 Sept 2026, 19:05 UTC
pgcollection is an open source extension to PostgreSQL. A type confusion issue in AWS pgcollection 2.0.0 through 2.1.1 might allow an authenticated remote user to execute arbitrary code as the postgres operating system user via crafted SQL statements that rely on mismatched type metadata in collection value retrieval and array conversion functions. To remediate this issue, users should upgrade to version 2.1.2 or later.
osv:CVE-2026-96883
Complete source record
{
"id": "60cdacb2532003897b471bf731d39e71a62d64e7d0b062d755144b0794887304",
"url": "https://osv.dev/vulnerability/CVE-2026-96883",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Type confusion in AWS pgcollection allows remote code execution",
"summary": "pgcollection is an open source extension to PostgreSQL. A type confusion issue in AWS pgcollection 2.0.0 through 2.1.1 might allow an authenticated remote user to execute arbitrary code as the postgres operating system user via crafted SQL statements that rely on mismatched type metadata in collection value retrieval and array conversion functions. To remediate this issue, users should upgrade to version 2.1.2 or later.",
"evidence": "osv:CVE-2026-96883",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-96883",
"aliases": [
"CVE-2026-96883",
"GHSA-g539-cj32-hv6r"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/aws/pgcollection",
"type": "GIT",
"events": [
{
"introduced": "134f76e34c597871058556973f854a13e482a9a6"
},
{
"fixed": "6177bebb97d48a28dc484ce58517c51ee68a2d28"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "2.0.0"
},
{
"last_affected": "2.1.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"fixed": "6177bebb97d48a28dc484ce58517c51ee68a2d28"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v2.1.2"
}
]
}
}
],
"versions": [
"v2.1.1",
"v2.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-96883.json"
}
}
],
"modified": "2026-10-28T02:30:49.246979175Z",
"provider": "osv",
"references": [
"https://aws.amazon.com/security/security-bulletins/2026-118-aws/",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/96xxx/CVE-2026-96883.json",
"https://github.com/aws/pgcollection/security/advisories/GHSA-g539-cj32-hv6r",
"https://nvd.nist.gov/vuln/detail/CVE-2026-96883",
"https://github.com/aws/pgcollection/releases/tag/v2.1.2"
],
"provider_metadata": {
"cwe_ids": [
"CWE-843"
],
"cna_assigner": "AMZN",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/96xxx/CVE-2026-96883.json"
}
},
"related_cves": [
{
"value": "CVE-2026-96883",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 517525,
"published_at": "2026-09-24T19:05:49.908+00:00"
}