Skip to content
Heist/ feed
Back to feed
Medium

Apache Livy: Restrict file access

Type: advisorySources: OSV

Malicious configuration can lead to unauthorized file access in Apache Livy. This issue affects Apache Livy 0.7.0 and 0.8.0 when connecting to Apache Spark 3.1 or later. A request that includes a Spark configuration value supported from Apache Spark version 3.1 can lead to users gaining access to files they do not have permissions to. For the vulnerability to be exploitable, the user needs to have access to Apache Livy's REST or JDBC interface and be able to send requests with arbitrary Spark configuration values. Users are recommended to upgrade to version 0.9.0 or later, which fixes the issue.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-60012
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 12:42 UTC · Revision 1

Source evidence

Apache Livy: Restrict file access

core-osv · Original source

Published 13 Mar 2026, 15:23 UTC

Malicious configuration can lead to unauthorized file access in Apache Livy. This issue affects Apache Livy 0.7.0 and 0.8.0 when connecting to Apache Spark 3.1 or later. A request that includes a Spark configuration value supported from Apache Spark version 3.1 can lead to users gaining access to files they do not have permissions to. For the vulnerability to be exploitable, the user needs to have access to Apache Livy's REST or JDBC interface and be able to send requests with arbitrary Spark configuration values. Users are recommended to upgrade to version 0.9.0 or later, which fixes the issue.

osv:CVE-2025-60012
Complete source record
{
  "id": "7d2507a15c51ddb41285add3a2a70757e40b9b8b7083252c1acdf0ba7b16eed0",
  "url": "https://osv.dev/vulnerability/CVE-2025-60012",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache Livy: Restrict file access",
    "summary": "Malicious configuration can lead to unauthorized file access in Apache Livy. This issue affects Apache Livy 0.7.0 and 0.8.0 when connecting to Apache Spark 3.1 or later. A request that includes a Spark configuration value supported from Apache Spark version 3.1 can lead to users gaining access to files they do not have permissions to. For the vulnerability to be exploitable, the user needs to have access to Apache Livy's REST or JDBC interface and be able to send requests with arbitrary Spark configuration values. Users are recommended to upgrade to version 0.9.0 or later, which fixes the issue.",
    "evidence": "osv:CVE-2025-60012",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2025-60012",
      "aliases": [
        "CVE-2025-60012",
        "GHSA-hm8x-rpgg-7855"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/livy",
              "type": "GIT",
              "events": [
                {
                  "introduced": "664503355d8bae763989ebac087122e306239d54"
                },
                {
                  "fixed": "7215f209b25b96488189567807eaded00953a492"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:livy:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0.7.0"
                      },
                      {
                        "fixed": "0.9.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-60012.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:28.770418237Z",
      "provider": "osv",
      "references": [
        "https://repo.maven.apache.org/maven2",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/60xxx/CVE-2025-60012.json",
        "https://lists.apache.org/thread/gpc85fwrgrbglpk9gm8tmcjzqnctx64w",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-60012"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-20"
        ],
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "0.7.0-incubating"
                  },
                  {
                    "fixed": "0.9.0-incubating"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/60xxx/CVE-2025-60012.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-60012",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 495493,
  "published_at": "2026-03-13T15:23:07.334+00:00"
}