UnratedFix available
phpmyadmin — security advisory
The configuration setup script (aka scripts/setup.php) in phpMyAdmin 2.11.x before 2.11.10.1 does not properly restrict key names in its output file, which allows remote attackers to execute arbitrary PHP code via a crafted POST request.
- Products
- phpmyadmin
- Affected versions
- Not specified
- Fixed versions
- 4:3.0.0
- CVEs
- CVE-2010-3055
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 22:42 UTC · Revision 1
Source evidence
The configuration setup script (aka scripts/setup.php) in phpMyAdmin 2.11.x before 2.11.10.1 does not properly restrict key names in its output file, which allows remote attackers to execute arbitrary PHP code via a crafted POST request.
osv:DEBIAN-CVE-2010-3055
phpmyadmin
Fixed versions: 4:3.0.0
phpmyadmin
Fixed versions: 4:3.0.0
phpmyadmin
Fixed versions: 4:3.0.0
Complete source record
{
"id": "eddf2b5fbbd734681550ee06e4da433b3749522556dcf1023bf8e8ca70df5b09",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2010-3055",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2010-3055",
"summary": "The configuration setup script (aka scripts/setup.php) in phpMyAdmin 2.11.x before 2.11.10.1 does not properly restrict key names in its output file, which allows remote attackers to execute arbitrary PHP code via a crafted POST request.",
"evidence": "osv:DEBIAN-CVE-2010-3055",
"products": [
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:3.0.0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:3.0.0",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:3.0.0",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2010-3055",
"aliases": [
"DEBIAN-CVE-2010-3055"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:3.0.0"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2010-3055.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:3.0.0"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2010-3055.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:3.0.0"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2010-3055.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T17:47:28.311894586Z",
"provider": "osv",
"upstream": [
"CVE-2010-3055"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2010-3055"
]
},
"related_cves": [
{
"value": "CVE-2010-3055",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 417098,
"published_at": "2010-08-24T20:00:01.113+00:00"
}