Skip to content
Heist/ feed
Back to feed
Low

icplayer tts-utils.js cross site scripting

Type: advisorySources: OSV

A vulnerability was found in icplayer up to 0.818. It has been rated as problematic. Affected by this issue is some unknown functionality of the file addons/Commons/src/tts-utils.js. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.819 is able to address this issue. The patch is identified as fa785969f213c76384f1fe67d47b17d57fcc60c8. It is recommended to upgrade the affected component. VDB-222290 is the identifier assigned to this vulnerability.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-4929
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 05:45 UTC · Revision 1

Source evidence

icplayer tts-utils.js cross site scripting

core-osv · Original source

Published 6 Mar 2023, 02:31 UTC

A vulnerability was found in icplayer up to 0.818. It has been rated as problematic. Affected by this issue is some unknown functionality of the file addons/Commons/src/tts-utils.js. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.819 is able to address this issue. The patch is identified as fa785969f213c76384f1fe67d47b17d57fcc60c8. It is recommended to upgrade the affected component. VDB-222290 is the identifier assigned to this vulnerability.

osv:CVE-2022-4929
Complete source record
{
  "id": "407009606227d3065106881d52ce5be53716fbc97da4aad74da4d9f8243fe868",
  "url": "https://osv.dev/vulnerability/CVE-2022-4929",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "icplayer tts-utils.js cross site scripting",
    "summary": "A vulnerability was found in icplayer up to 0.818. It has been rated as problematic. Affected by this issue is some unknown functionality of the file addons/Commons/src/tts-utils.js. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.819 is able to address this issue. The patch is identified as fa785969f213c76384f1fe67d47b17d57fcc60c8. It is recommended to upgrade the affected component. VDB-222290 is the identifier assigned to this vulnerability.",
    "evidence": "osv:CVE-2022-4929",
    "products": [],
    "severity": "low",
    "structured": {
      "id": "CVE-2022-4929",
      "aliases": [
        "CVE-2022-4929"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/icplayer/icplayer",
              "type": "GIT",
              "events": [
                {
                  "introduced": "1f39a99875720dbb14c0ef0ec664986ab44fb424"
                },
                {
                  "fixed": "fa785969f213c76384f1fe67d47b17d57fcc60c8"
                },
                {
                  "fixed": "a3110b440f16beae1ba591b2b9ba07f8a8f261ef"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0.818"
                      },
                      {
                        "last_affected": "0.818"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StandaloneSingleVersion"
                  },
                  {
                    "range": [
                      {
                        "fixed": "fa785969f213c76384f1fe67d47b17d57fcc60c8"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "a3110b440f16beae1ba591b2b9ba07f8a8f261ef"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v0.819"
                  }
                ]
              }
            }
          ],
          "versions": [
            "0.818",
            "v0.818"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-4929.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:26.487708550Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/4xxx/CVE-2022-4929.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-4929",
        "https://vuldb.com/?id.222290",
        "https://github.com/icplayer/icplayer/pull/885",
        "https://vuldb.com/?ctiid.222290",
        "https://github.com/icplayer/icplayer/commit/fa785969f213c76384f1fe67d47b17d57fcc60c8",
        "https://github.com/icplayer/icplayer/releases/tag/v0.819"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "VulDB",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/4xxx/CVE-2022-4929.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-4929",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 492830,
  "published_at": "2023-03-06T02:31:04.497+00:00"
}