Skip to content
Heist/ feed
Back to feed
HighFix available

Discourse: Stored oEmbed HTML injection via allowed iframe

Type: advisorySources: OSV

Discourse is an open-source discussion platform. Prior to 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9, oEmbed processing treated an entire attacker-controlled HTML fragment as trusted when the fragment contained an iframe whose source matched the configured allowlist. A user with posting permission who controlled a public webpage and its oEmbed response could combine an allowlisted iframe with unrelated sibling HTML or CSS, causing stored visual overlays or other styled content to appear in post content and enabling misleading or fraudulent user interfaces. Exploitation requires a posting account, control of the fetched webpage and oEmbed response, and an allowlisted iframe source. The issue affects content integrity but does not expose restricted data, disrupt availability, or require interaction with Discourse Content Security Policy. This issue is fixed in versions 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9.

Products
discourse
Affected versions
Not specified
Fixed versions
2026.1.9, 2026.7.3, 2026.8.1, 2026.9.0
CVEs
CVE-2026-91159
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 14:09 UTC · Revision 1

Source evidence

Discourse: Stored oEmbed HTML injection via allowed iframe

core-osv · Original source

Published 21 Oct 2026, 08:47 UTC

Discourse is an open-source discussion platform. Prior to 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9, oEmbed processing treated an entire attacker-controlled HTML fragment as trusted when the fragment contained an iframe whose source matched the configured allowlist. A user with posting permission who controlled a public webpage and its oEmbed response could combine an allowlisted iframe with unrelated sibling HTML or CSS, causing stored visual overlays or other styled content to appear in post content and enabling misleading or fraudulent user interfaces. Exploitation requires a posting account, control of the fetched webpage and oEmbed response, and an allowlisted iframe source. The issue affects content integrity but does not expose restricted data, disrupt availability, or require interaction with Discourse Content Security Policy. This issue is fixed in versions 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9.

osv:BIT-discourse-2026-91159

discourse

Fixed versions: 2026.1.9, 2026.7.3, 2026.8.1, 2026.9.0

Complete source record
{
  "id": "ec2533880570ffbbb16d81cd4ce23a34b922eb53c763a33b8d7ffaf739206d72",
  "url": "https://osv.dev/vulnerability/BIT-discourse-2026-91159",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Discourse: Stored oEmbed HTML injection via allowed iframe",
    "summary": "Discourse is an open-source discussion platform. Prior to 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9, oEmbed processing treated an entire attacker-controlled HTML fragment as trusted when the fragment contained an iframe whose source matched the configured allowlist. A user with posting permission who controlled a public webpage and its oEmbed response could combine an allowlisted iframe with unrelated sibling HTML or CSS, causing stored visual overlays or other styled content to appear in post content and enabling misleading or fraudulent user interfaces. Exploitation requires a posting account, control of the fetched webpage and oEmbed response, and an allowlisted iframe source. The issue affects content integrity but does not expose restricted data, disrupt availability, or require interaction with Discourse Content Security Policy. This issue is fixed in versions 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9.",
    "evidence": "osv:BIT-discourse-2026-91159",
    "products": [
      {
        "name": {
          "value": "discourse",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2026.1.9",
            "evidence": "/affected/0/ranges"
          },
          {
            "value": "2026.7.3",
            "evidence": "/affected/0/ranges"
          },
          {
            "value": "2026.8.1",
            "evidence": "/affected/0/ranges"
          },
          {
            "value": "2026.9.0",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "BIT-discourse-2026-91159",
      "aliases": [
        "BIT-discourse-2026-91159",
        "CVE-2026-91159",
        "GHSA-f9jx-vv33-4282"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2026.1.9"
                },
                {
                  "introduced": "2026.7.0"
                },
                {
                  "fixed": "2026.7.3"
                },
                {
                  "introduced": "2026.8.0"
                },
                {
                  "fixed": "2026.8.1"
                },
                {
                  "introduced": "2026.8.99"
                },
                {
                  "fixed": "2026.9.0"
                }
              ]
            }
          ],
          "package": {
            "name": "discourse",
            "purl": "pkg:bitnami/discourse",
            "ecosystem": "Bitnami"
          },
          "severity": [
            {
              "type": "CVSS_V3",
              "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N"
            }
          ],
          "database_specific": {
            "source": "https://github.com/bitnami/vulndb/tree/main/data/discourse/BIT-discourse-2026-91159.json"
          }
        }
      ],
      "modified": "2026-10-21T12:11:22.525535738Z",
      "provider": "osv",
      "references": [
        "https://github.com/discourse/discourse/commit/0953b31f5c2949d7d6ab5f6dc4c5e2f1b8bf0b22",
        "https://github.com/discourse/discourse/commit/3fc2bad6cdca47b00958330d1ee612aa141b039a",
        "https://github.com/discourse/discourse/commit/dde8bc4fb6200139f5eff7e100b0f3e829d37ab3",
        "https://github.com/discourse/discourse/commit/ed6f83f123d1a4c6c6c7e64c8a2233e3cb6a28d7",
        "https://github.com/discourse/discourse/security/advisories/GHSA-f9jx-vv33-4282",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-91159"
      ],
      "provider_metadata": {
        "cpes": [
          "cpe:2.3:a:discourse:discourse:*:*:*:*:stable:*:*:*",
          "cpe:2.3:a:discourse:discourse:*:*:*:*:beta:*:*:*"
        ],
        "severity": "High"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-91159",
        "evidence": "/aliases"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/database_specific/severity"
  },
  "source_id": "core-osv",
  "document_id": 393031,
  "published_at": "2026-10-21T08:47:55.895+00:00"
}