Skip to content
Heist/ feed
Back to feed
Critical

Security advisory

Type: advisorySources: OSVCVE: CVE-2020-11052

In Sorcery before 0.15.0, there is a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout. This has been patched in 0.15.0.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2020-11052
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 10:47 UTC · Revision 1

Source evidence

CVE-2020-11052

core-osv · Original source

Published 7 May 2020, 21:15 UTC

In Sorcery before 0.15.0, there is a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout. This has been patched in 0.15.0.

osv:CVE-2020-11052
Complete source record
{
  "id": "b117c122e9e49e5fd10b4c3485e94e600ec7fb6b0b21bdcce39d0dcdf328f3e7",
  "url": "https://osv.dev/vulnerability/CVE-2020-11052",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2020-11052",
    "summary": "In Sorcery before 0.15.0, there is a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout. This has been patched in 0.15.0.",
    "evidence": "osv:CVE-2020-11052",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2020-11052",
      "aliases": [
        "CVE-2020-11052",
        "GHSA-jc8m-cxhj-668x"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/sorcery/sorcery",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "e81c64c1775ad815ae42c75c4be0af41aed69e87"
                },
                {
                  "fixed": "0f116d223826895a73b12492f17486e5d54ab7a7"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:sorcery_project:sorcery:*:*:*:*:*:ruby:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "0.15.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "0f116d223826895a73b12492f17486e5d54ab7a7"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v0.14.0",
            "v0.13.0",
            "v0.12.0",
            "0.11.0",
            "v0.10.3",
            "v0.10.2",
            "v0.10.1",
            "v0.10.0",
            "v0.8.6",
            "v0.8.5",
            "show",
            "v0.8.3",
            "v0.8.2",
            "v0.8.1",
            "v0.8.0",
            "v0.7.13",
            "v0.7.12",
            "v0.7.11",
            "v0.7.10",
            "v0.7.9",
            "v0.7.8",
            "v0.7.7",
            "v0.7.6",
            "v0.7.5",
            "v0.7.4",
            "v0.7.3",
            "v0.7.2",
            "v0.7.1",
            "v0.7.0",
            "v0.6.1",
            "v0.6.0",
            "v0.5.30",
            "v0.5.3",
            "v0.5.21",
            "v0.5.2",
            "v0.5.1",
            "v0.5.0",
            "v0.4.2",
            "v0.4.1",
            "v0.4.0",
            "v0.3.1",
            "v0.3.0",
            "v0.2.1",
            "v0.2.0",
            "v0.1.4",
            "v0.1.3",
            "v0.1.2",
            "v0.1.1",
            "v0.1.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-11052.json"
          }
        }
      ],
      "modified": "2026-10-20T10:51:40.909085975Z",
      "provider": "osv",
      "references": [
        "https://github.com/Sorcery/sorcery/issues/231",
        "https://github.com/Sorcery/sorcery/security/advisories/GHSA-jc8m-cxhj-668x",
        "https://github.com/Sorcery/sorcery/commit/0f116d223826895a73b12492f17486e5d54ab7a7",
        "https://github.com/Sorcery/sorcery/pull/235"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2020-11052",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 382757,
  "published_at": "2020-05-07T21:15:11.483+00:00"
}