libxstream-java — security advisory
XStream before version 1.4.14 is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker to run arbitrary shell commands only by manipulating the processed input stream. Only users who rely on blocklists are affected. Anyone using XStream's Security Framework allowlist is not affected. The linked advisory provides code workarounds for users who cannot upgrade. The issue is fixed in version 1.4.14.
- Products
- libxstream-java
- Affected versions
- Not specified
- Fixed versions
- 1.4.14-1
- CVEs
- CVE-2020-26217
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 09:02 UTC · Revision 1
Source evidence
XStream before version 1.4.14 is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker to run arbitrary shell commands only by manipulating the processed input stream. Only users who rely on blocklists are affected. Anyone using XStream's Security Framework allowlist is not affected. The linked advisory provides code workarounds for users who cannot upgrade. The issue is fixed in version 1.4.14.
osv:DEBIAN-CVE-2020-26217
libxstream-java
Fixed versions: 1.4.14-1
libxstream-java
Fixed versions: 1.4.14-1
libxstream-java
Fixed versions: 1.4.14-1
Complete source record
{
"id": "f84e1c8d86d4d43bd92b349ba538843125812f66f5aaef03adb97d75d19f10d8",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2020-26217",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2020-26217",
"summary": "XStream before version 1.4.14 is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker to run arbitrary shell commands only by manipulating the processed input stream. Only users who rely on blocklists are affected. Anyone using XStream's Security Framework allowlist is not affected. The linked advisory provides code workarounds for users who cannot upgrade. The issue is fixed in version 1.4.14.",
"evidence": "osv:DEBIAN-CVE-2020-26217",
"products": [
{
"name": {
"value": "libxstream-java",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.4.14-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libxstream-java",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.4.14-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libxstream-java",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.4.14-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2020-26217",
"aliases": [
"DEBIAN-CVE-2020-26217"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.4.14-1"
}
]
}
],
"package": {
"name": "libxstream-java",
"purl": "pkg:deb/debian/libxstream-java?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2020-26217.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.4.14-1"
}
]
}
],
"package": {
"name": "libxstream-java",
"purl": "pkg:deb/debian/libxstream-java?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2020-26217.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.4.14-1"
}
]
}
],
"package": {
"name": "libxstream-java",
"purl": "pkg:deb/debian/libxstream-java?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2020-26217.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-08T09:47:24.450291787Z",
"provider": "osv",
"upstream": [
"CVE-2020-26217"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2020-26217"
]
},
"related_cves": [
{
"value": "CVE-2020-26217",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 98853,
"published_at": "2020-11-16T21:15:12.893+00:00"
}