Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2017-20158

** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in vova07 Yii2 FileAPI Widget up to 0.1.8. It has been declared as problematic. Affected by this vulnerability is the function run of the file actions/UploadAction.php. The manipulation of the argument file leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.1.9 is able to address this issue. The identifier of the patch is c00d1e4fc912257fca1fce66d7a163bdbb4c8222. It is recommended to upgrade the affected component. The identifier VDB-217141 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2017-20158
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 10:31 UTC · Revision 1

Source evidence

CVE-2017-20158

core-osv · Original source

Published 31 Dec 2022, 11:15 UTC

** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in vova07 Yii2 FileAPI Widget up to 0.1.8. It has been declared as problematic. Affected by this vulnerability is the function run of the file actions/UploadAction.php. The manipulation of the argument file leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.1.9 is able to address this issue. The identifier of the patch is c00d1e4fc912257fca1fce66d7a163bdbb4c8222. It is recommended to upgrade the affected component. The identifier VDB-217141 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

osv:CVE-2017-20158
Complete source record
{
  "id": "fed6b9d8e21fd43becbd3e1e550656c4f23b1c05d6e421dcf8af61625868a59a",
  "url": "https://osv.dev/vulnerability/CVE-2017-20158",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2017-20158",
    "summary": "** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in vova07 Yii2 FileAPI Widget up to 0.1.8. It has been declared as problematic. Affected by this vulnerability is the function run of the file actions/UploadAction.php. The manipulation of the argument file leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.1.9 is able to address this issue. The identifier of the patch is c00d1e4fc912257fca1fce66d7a163bdbb4c8222. It is recommended to upgrade the affected component. The identifier VDB-217141 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.",
    "evidence": "osv:CVE-2017-20158",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2017-20158",
      "aliases": [
        "CVE-2017-20158",
        "GHSA-j82x-fh8h-326g"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/vova07/yii2-fileapi-widget",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "110086027b6da7755834ff93ebc4476ef7b10b15"
                },
                {
                  "fixed": "c00d1e4fc912257fca1fce66d7a163bdbb4c8222"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:yii2_fileapi_widget_project:yii2_fileapi_widget:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "0.1.9"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "c00d1e4fc912257fca1fce66d7a163bdbb4c8222"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "110086027b6da7755834ff93ebc4476ef7b10b15"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "0.1.9"
                  }
                ]
              }
            }
          ],
          "versions": [
            "0.1.8",
            "0.1.7",
            "0.1.6",
            "0.1.5",
            "0.1.4",
            "0.1.3",
            "0.1.2",
            "0.1.1",
            "0.1.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-20158.json"
          }
        }
      ],
      "modified": "2026-10-20T10:50:32.321175968Z",
      "provider": "osv",
      "references": [
        "https://github.com/vova07/yii2-fileapi-widget/releases/tag/0.1.9",
        "https://vuldb.com/?ctiid.217141",
        "https://vuldb.com/?id.217141",
        "https://github.com/vova07/yii2-fileapi-widget/commit/c00d1e4fc912257fca1fce66d7a163bdbb4c8222"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2017-20158",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 381822,
  "published_at": "2022-12-31T11:15:08.587+00:00"
}