Security advisory
Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. Prior to version 3.1.0, a malicious SAML payload can require transforms that consume significant system resources to process, thereby resulting in reduced or denied service. This would be an effective way to perform a denial-of-service attack. This has been resolved in version 3.1.0. The resolution is to limit the number of allowable transforms to 2.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-39171
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:53 UTC · Revision 1
Source evidence
Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. Prior to version 3.1.0, a malicious SAML payload can require transforms that consume significant system resources to process, thereby resulting in reduced or denied service. This would be an effective way to perform a denial-of-service attack. This has been resolved in version 3.1.0. The resolution is to limit the number of allowable transforms to 2.
osv:CVE-2021-39171
Complete source record
{
"id": "d6002898a272740268d432e4b74f3fd7d61c8d8f045dec0aea8b83ba898d3c50",
"url": "https://osv.dev/vulnerability/CVE-2021-39171",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-39171",
"summary": "Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. Prior to version 3.1.0, a malicious SAML payload can require transforms that consume significant system resources to process, thereby resulting in reduced or denied service. This would be an effective way to perform a denial-of-service attack. This has been resolved in version 3.1.0. The resolution is to limit the number of allowable transforms to 2.",
"evidence": "osv:CVE-2021-39171",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2021-39171",
"aliases": [
"CVE-2021-39171",
"GHSA-5379-r78w-42h2"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/node-saml/passport-saml",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "f1e00b64c21a725f545e675cd810bbaa435a3972"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:passport-saml_project:passport-saml:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.1.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v3.0.0",
"v2.0.5",
"v2.0.4",
"v2.0.3",
"v2.0.2",
"v2.0.1",
"v2.0.0",
"v1.5.0",
"v1.4.2",
"v1.4.1",
"v1.4.0",
"v1.3.5",
"v1.3.2",
"v1.3.1",
"v1.3.0",
"v1.2.0",
"v1.1.0",
"v1.0.0",
"v0.35.0",
"v0.34.0",
"v0.33.0",
"v0.32.1",
"v0.32.0",
"v0.30.0",
"v0.20.2",
"v0.16.2",
"v0.16.1",
"v0.16.0",
"v0.15.0",
"v0.14.0",
"v0.13.0",
"v0.12.0",
"v0.11.1",
"v0.11.0",
"v0.10.0",
"v0.9.2",
"v0.9.1",
"v0.9.0",
"v0.8.0",
"v0.7.0",
"v0.6.2",
"v0.6.1",
"v0.6.0",
"v0.5.3",
"v0.5.2",
"v0.5.1",
"v0.5.0",
"v0.4.0",
"v0.3.0",
"v0.2.1",
"v0.2.0",
"v0.1.0",
"v0.0.3",
"0.0.3"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-39171.json"
}
}
],
"modified": "2026-10-20T10:54:54.177327449Z",
"provider": "osv",
"references": [
"https://github.com/node-saml/passport-saml/security/advisories/GHSA-5379-r78w-42h2",
"https://github.com/node-saml/passport-saml/pull/595"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-39171",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 386423,
"published_at": "2021-08-27T22:15:07.267+00:00"
}