Medium
POST SMTP Mailer < 2.5.7 - Arbitrary Log Deletion via CSRF
Type: advisorySources: OSV
The POST SMTP Mailer WordPress plugin before 2.5.7 does not have proper CSRF checks in some AJAX actions, which could allow attackers to make logged in users with the manage_postman_smtp capability delete arbitrary logs via a CSRF attack.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-3178
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 11:15 UTC · Revision 1
Source evidence
POST SMTP Mailer < 2.5.7 - Arbitrary Log Deletion via CSRF
core-osv · Original sourcePublished 16 Jan 2024, 15:55 UTC
The POST SMTP Mailer WordPress plugin before 2.5.7 does not have proper CSRF checks in some AJAX actions, which could allow attackers to make logged in users with the manage_postman_smtp capability delete arbitrary logs via a CSRF attack.
osv:CVE-2023-3178
Complete source record
{
"id": "f42325033e66347da76ee9f69b6bc3db515a0134fad440c12a9534925b6857f8",
"url": "https://osv.dev/vulnerability/CVE-2023-3178",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "POST SMTP Mailer < 2.5.7 - Arbitrary Log Deletion via CSRF",
"summary": "The POST SMTP Mailer WordPress plugin before 2.5.7 does not have proper CSRF checks in some AJAX actions, which could allow attackers to make logged in users with the manage_postman_smtp capability delete arbitrary logs via a CSRF attack.",
"evidence": "osv:CVE-2023-3178",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2023-3178",
"aliases": [
"CVE-2023-3178"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wpexpertsio/post-smtp",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "8cf2ee9a7e30d97e947a271d9d6c8245f09293fe"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wpexperts:post_smtp:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.5.7"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.5.6",
"2.5.5",
"2.5.4",
"2.5.3",
"2.5.2",
"2.5.1",
"2.5.0",
"2.5-rc.3",
"2.5-rc.2",
"2.5-rc.1",
"2.5-beta.1",
"2.4.3",
"2.4.2-beta.2",
"2.4.2",
"2.4.1",
"2.4",
"2.4-beta.1",
"2.3.1",
"2.3",
"2.2.1",
"2.2",
"2.2-beta.2",
"2.1.8",
"2.1.7",
"2.1.6",
"2.1.4",
"2.1.4-rc.2",
"2.1.4-rc.1",
"2.1.4-beta.1",
"2.1.2",
"2.1.2-rc.2",
"2.1.2-rc.1",
"2.1.2-beta-1",
"2.1.1.1",
"2.1.1",
"2.1",
"2.1-beta.1",
"2.0.27",
"2.0.26",
"2.0.25-beta.1",
"2.0.25",
"2.0.24",
"2.0.23",
"2.0.22",
"2.0.21",
"2.0.20",
"2.0.19",
"2.0.18",
"2.0.17",
"2.0.16",
"2.0.15",
"2.0.14",
"2.0.13",
"2.0.12",
"2.0.11",
"2.0.10",
"2.0.9",
"2.0.8",
"2.0.7",
"2.0.6",
"2.0.5",
"2.0.4",
"2.0.3",
"2.0.2",
"2.0.1",
"v1.9.8",
"v1.9.7",
"v1.9.6",
"v1.9.5",
"v1.9.4",
"v1.9.3",
"v.1.9.2",
"v.1.9.1",
"v.1.9.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-3178.json"
}
}
],
"modified": "2026-10-28T02:30:28.048582358Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/3xxx/CVE-2023-3178.json",
"https://nvd.nist.gov/vuln/detail/CVE-2023-3178",
"https://wpscan.com/vulnerability/5341cb5d-d204-49e1-b013-f8959461995f/"
],
"provider_metadata": {
"cna_assigner": "WPScan",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "2.5.0"
},
{
"fixed": "2.5.7"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/3xxx/CVE-2023-3178.json"
}
},
"related_cves": [
{
"value": "CVE-2023-3178",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 494883,
"published_at": "2024-01-16T15:55:29.719+00:00"
}