Skip to content
Heist/ feed
Back to feed
MediumFix available

ruby-net-imap — security advisory

Type: advisorySources: OSVAdvisory ID: ALPINE-CVE-2026-42258

Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.4.24, 0.5.14, and 0.6.4, symbol arguments to commands are vulnerable to a CRLF Injection / IMAP Command injection via Symbol arguments passed to IMAP commands. This issue has been patched in versions 0.4.24, 0.5.14, and 0.6.4.

Products
ruby-net-imap
Affected versions
Not specified
Fixed versions
0.4.25-r0
CVEs
CVE-2026-42258
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 17:56 UTC · Revision 1

Source evidence

ALPINE-CVE-2026-42258

core-osv · Original source

Published 9 May 2026, 20:16 UTC

Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.4.24, 0.5.14, and 0.6.4, symbol arguments to commands are vulnerable to a CRLF Injection / IMAP Command injection via Symbol arguments passed to IMAP commands. This issue has been patched in versions 0.4.24, 0.5.14, and 0.6.4.

osv:ALPINE-CVE-2026-42258

ruby-net-imap

Fixed versions: 0.4.25-r0

Complete source record
{
  "id": "280b9d78ee89ff8799db9bf198daf4fd500670abeef9ba96a2ebfdb084db8ca6",
  "url": "https://osv.dev/vulnerability/ALPINE-CVE-2026-42258",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "ALPINE-CVE-2026-42258",
    "summary": "Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.4.24, 0.5.14, and 0.6.4, symbol arguments to commands are vulnerable to a CRLF Injection / IMAP Command injection via Symbol arguments passed to IMAP commands. This issue has been patched in versions 0.4.24, 0.5.14, and 0.6.4.",
    "evidence": "osv:ALPINE-CVE-2026-42258",
    "products": [
      {
        "name": {
          "value": "ruby-net-imap",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.4.25-r0",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "ALPINE-CVE-2026-42258",
      "aliases": [
        "ALPINE-CVE-2026-42258"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.4.25-r0"
                }
              ]
            }
          ],
          "package": {
            "name": "ruby-net-imap",
            "purl": "pkg:apk/alpine/ruby-net-imap?arch=source",
            "ecosystem": "Alpine:v3.21"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-42258.json"
          },
          "ecosystem_specific": {}
        }
      ],
      "modified": "2026-10-27T12:30:04.033578896Z",
      "provider": "osv",
      "upstream": [
        "CVE-2026-42258"
      ],
      "references": [
        "https://security.alpinelinux.org/vuln/CVE-2026-42258"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2026-42258",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 461534,
  "published_at": "2026-05-09T20:16:28.623+00:00"
}