ghostscript — security advisory
An issue was discovered in Artifex Ghostscript before 9.24. The .setdistillerkeys PostScript command is accepted even though it is not intended for use during document processing (e.g., after the startup phase). This leads to memory corruption, allowing remote attackers able to supply crafted PostScript to crash the interpreter or possibly have unspecified other impact. Note: A reputable source believes that the CVE is potentially a duplicate of CVE-2018-15910 as explained in Red Hat bugzilla (https://bugzilla.redhat.com/show_bug.cgi?id=1626193)
- Products
- ghostscript
- Affected versions
- Not specified
- Fixed versions
- 9.25~dfsg-1
- CVEs
- CVE-2018-16585
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:08 UTC · Revision 1
Source evidence
An issue was discovered in Artifex Ghostscript before 9.24. The .setdistillerkeys PostScript command is accepted even though it is not intended for use during document processing (e.g., after the startup phase). This leads to memory corruption, allowing remote attackers able to supply crafted PostScript to crash the interpreter or possibly have unspecified other impact. Note: A reputable source believes that the CVE is potentially a duplicate of CVE-2018-15910 as explained in Red Hat bugzilla (https://bugzilla.redhat.com/show_bug.cgi?id=1626193)
osv:DEBIAN-CVE-2018-16585
ghostscript
Fixed versions: 9.25~dfsg-1
ghostscript
Fixed versions: 9.25~dfsg-1
ghostscript
Fixed versions: 9.25~dfsg-1
Complete source record
{
"id": "abcd7b3fb134bd5f1f6c4132db0b0f6e0221e40b707bfc1e59e73188098f702d",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2018-16585",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2018-16585",
"summary": "An issue was discovered in Artifex Ghostscript before 9.24. The .setdistillerkeys PostScript command is accepted even though it is not intended for use during document processing (e.g., after the startup phase). This leads to memory corruption, allowing remote attackers able to supply crafted PostScript to crash the interpreter or possibly have unspecified other impact. Note: A reputable source believes that the CVE is potentially a duplicate of CVE-2018-15910 as explained in Red Hat bugzilla (https://bugzilla.redhat.com/show_bug.cgi?id=1626193)",
"evidence": "osv:DEBIAN-CVE-2018-16585",
"products": [
{
"name": {
"value": "ghostscript",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "9.25~dfsg-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ghostscript",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "9.25~dfsg-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ghostscript",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "9.25~dfsg-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2018-16585",
"aliases": [
"DEBIAN-CVE-2018-16585"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "9.25~dfsg-1"
}
]
}
],
"package": {
"name": "ghostscript",
"purl": "pkg:deb/debian/ghostscript?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-16585.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "9.25~dfsg-1"
}
]
}
],
"package": {
"name": "ghostscript",
"purl": "pkg:deb/debian/ghostscript?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-16585.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "9.25~dfsg-1"
}
]
}
],
"package": {
"name": "ghostscript",
"purl": "pkg:deb/debian/ghostscript?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-16585.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:03:00.662231254Z",
"provider": "osv",
"upstream": [
"CVE-2018-16585"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2018-16585"
]
},
"related_cves": [
{
"value": "CVE-2018-16585",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 420096,
"published_at": "2018-09-06T14:29:00.76+00:00"
}