cyface Terms and Conditions Module views.py returnTo redirect
A vulnerability has been found in cyface Terms and Conditions Module up to 2.0.9 and classified as problematic. Affected by this vulnerability is the function returnTo of the file termsandconditions/views.py. The manipulation leads to open redirect. The attack can be launched remotely. Upgrading to version 2.0.10 is able to address this issue. The name of the patch is 03396a1c2e0af95e12a45c5faef7e47a4b513e1a. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216175.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-4589
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 15:56 UTC · Revision 1
Source evidence
cyface Terms and Conditions Module views.py returnTo redirect
core-osv · Original sourcePublished 17 Dec 2022, 00:00 UTC
A vulnerability has been found in cyface Terms and Conditions Module up to 2.0.9 and classified as problematic. Affected by this vulnerability is the function returnTo of the file termsandconditions/views.py. The manipulation leads to open redirect. The attack can be launched remotely. Upgrading to version 2.0.10 is able to address this issue. The name of the patch is 03396a1c2e0af95e12a45c5faef7e47a4b513e1a. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216175.
osv:CVE-2022-4589
Complete source record
{
"id": "c7ba250f5efb0550b6cc3f083ac4f216cce26c180eaed94fd22ef73c9d694f55",
"url": "https://osv.dev/vulnerability/CVE-2022-4589",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "cyface Terms and Conditions Module views.py returnTo redirect",
"summary": "A vulnerability has been found in cyface Terms and Conditions Module up to 2.0.9 and classified as problematic. Affected by this vulnerability is the function returnTo of the file termsandconditions/views.py. The manipulation leads to open redirect. The attack can be launched remotely. Upgrading to version 2.0.10 is able to address this issue. The name of the patch is 03396a1c2e0af95e12a45c5faef7e47a4b513e1a. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216175.",
"evidence": "osv:CVE-2022-4589",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2022-4589",
"aliases": [
"CVE-2022-4589",
"GHSA-6rmf-cv6p-4h27",
"PYSEC-2026-805"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/cyface/django-termsandconditions",
"type": "GIT",
"events": [
{
"introduced": "01ef7b2f4554e858e57b9e424b7019d23b586087"
},
{
"fixed": "03396a1c2e0af95e12a45c5faef7e47a4b513e1a"
},
{
"fixed": "32c49024f8055f2a1c3b73bb39462a631aed881c"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "2.0.0"
},
{
"last_affected": "2.0.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "2.0.1"
},
{
"last_affected": "2.0.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "2.0.2"
},
{
"last_affected": "2.0.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "2.0.3"
},
{
"last_affected": "2.0.3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "2.0.4"
},
{
"last_affected": "2.0.4"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "2.0.5"
},
{
"last_affected": "2.0.5"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "2.0.6"
},
{
"last_affected": "2.0.6"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "2.0.8"
},
{
"last_affected": "2.0.8"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "2.0.9"
},
{
"last_affected": "2.0.9"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"fixed": "03396a1c2e0af95e12a45c5faef7e47a4b513e1a"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "32c49024f8055f2a1c3b73bb39462a631aed881c"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v2.0.10"
}
]
}
}
],
"versions": [
"2.0.0",
"2.0.1",
"2.0.2",
"2.0.3",
"2.0.4",
"2.0.5",
"2.0.6",
"2.0.8",
"2.0.9",
"v2.0.9",
"v2.0.8",
"v2.0.6",
"v2.0.5",
"v2.0.4",
"v2.0.3",
"v2.0.2",
"v2.0.1",
"v2.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-4589.json"
}
}
],
"modified": "2026-10-28T02:30:30.145943845Z",
"provider": "osv",
"references": [
"https://github.com/cyface/django-termsandconditions/releases/tag/v2.0.10",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/4xxx/CVE-2022-4589.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-4589",
"https://vuldb.com/?id.216175",
"https://github.com/cyface/django-termsandconditions/commit/03396a1c2e0af95e12a45c5faef7e47a4b513e1a",
"https://github.com/cyface/django-termsandconditions/pull/239"
],
"provider_metadata": {
"cwe_ids": [
"CWE-601"
],
"cna_assigner": "VulDB",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "2.0.7"
},
{
"last_affected": "2.0.7"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/4xxx/CVE-2022-4589.json"
}
},
"related_cves": [
{
"value": "CVE-2022-4589",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 497069,
"published_at": "2022-12-17T00:00:00+00:00"
}