Medium
Security advisory
WooCommerce before 3.5.5 allows XSS via a Photoswipe caption.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-9168
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 06:52 UTC · Revision 1
Source evidence
WooCommerce before 3.5.5 allows XSS via a Photoswipe caption.
osv:CVE-2019-9168
Complete source record
{
"id": "cda9242508260172a7255897fb9bc5d6ad3a454c539213741b9beb8e32406802",
"url": "https://osv.dev/vulnerability/CVE-2019-9168",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-9168",
"summary": "WooCommerce before 3.5.5 allows XSS via a Photoswipe caption.",
"evidence": "osv:CVE-2019-9168",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2019-9168",
"aliases": [
"CVE-2019-9168"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/woocommerce/woocommerce",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "359d113018a54d0d3fba14935473639db02ee562"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.5.5"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"3.5.4",
"3.5.3",
"3.5.2",
"3.5.1",
"3.5.0",
"3.5.0-rc.2",
"3.5.0-rc.1",
"3.5.0-beta.1",
"3.4.0-rc.2",
"3.4.0-rc.1",
"3.4.0-beta.2",
"3.4.0-beta.1",
"3.3.0-rc.1",
"3.3.0-beta.2",
"3.3.0-beta.1",
"3.2.0-rc.1",
"3.2.0-beta.2",
"3.2.0-beta.1",
"3.1.0-rc.1",
"3.1.0-beta.2",
"3.1.0-beta.1",
"3.1.0-beta-1",
"3.0.0",
"3.0.0-rc.2",
"3.0.0-rc.1",
"2.7.0-RC1",
"2.7.0-beta-4",
"2.7.0-beta-3",
"2.7.0-beta-2",
"2.7.0-beta-1",
"2.6.3",
"2.6.2",
"2.6.1",
"2.6.0",
"2.6.0-RC2",
"2.6.0-RC1",
"2.6.0-beta-4",
"2.6.0-beta-3",
"2.6.0-beta-2",
"2.6.0-beta-1",
"2.5.0",
"2.5.0-RC3",
"2.5.0-RC2",
"2.5.0-RC1",
"2.5.0-beta-3",
"2.5.0-beta-1",
"2.4.6",
"2.4.5",
"2.4.4",
"2.4.3",
"2.4.2",
"2.4.1",
"2.4.0",
"2.4.0-RC1",
"2.4.0-beta-4",
"2.4.0-beta-3",
"2.4.0-beta-2",
"2.4.0-beta-1",
"2.3.6",
"2.3.5",
"2.3.4",
"2.3.3",
"2.3.2",
"2.3.1",
"2.3.0",
"2.3.0-RC1",
"2.3.0-beta-3",
"2.3.0-beta-2",
"2.3.0-beta-1",
"2.2.4",
"v2.2.3",
"2.2.3",
"v2.2.2",
"2.2.2",
"v2.2.1",
"2.2.1",
"v2.2.0-RC1",
"2.2.0-RC1",
"v2.2-beta-3",
"2.2-beta-3",
"v2.2-beta-2",
"2.2-beta-2",
"v2.2-beta-1",
"2.2-beta-1",
"v2.1.0",
"2.1.0",
"v2.1.0-RC2",
"2.1.0-RC2",
"v2.1.0-RC1",
"2.1.0-RC1",
"v2.1.0-beta-3",
"2.1.0-beta-3",
"v2.1.0-beta-2",
"2.1.0-beta-2",
"v2.1.0-beta-1",
"2.1.0-beta-1",
"v2.0.9",
"2.0.9",
"v2.0.8",
"2.0.8",
"v2.0.7",
"2.0.7",
"v2.0.6",
"2.0.6",
"v2.0.4",
"2.0.4",
"v2.0.5",
"2.0.5",
"v2.0.3",
"2.0.3",
"v2.0.2",
"2.0.2",
"v2.0.1",
"2.0.1",
"v2.0.0",
"2.0.0",
"v2.0.0-RC3",
"2.0.0-RC3",
"v2.0.0-RC2",
"2.0.0-RC2",
"v2.0.0-RC1",
"2.0.0-RC1",
"v2.0.0-beta3",
"2.0.0-beta3",
"v2.0.0-beta2",
"2.0.0-beta2",
"v2.0.0-beta1",
"2.0.0-beta1",
"v2.0-beta-0",
"2.0-beta-0",
"v1.6.5.1",
"1.6.5.1",
"v1.6.5",
"1.6.5",
"v1.6.4",
"1.6.4",
"v1.6.3",
"1.6.3",
"v1.6.2",
"1.6.2",
"v1.6.1",
"1.6.1",
"v1.6.0",
"1.6.0",
"v1.6-beta-1",
"1.6-beta-1",
"v1.5.8",
"1.5.8",
"v1.5.7.1",
"1.5.7.1",
"v1.5.7",
"1.5.7",
"v1.5.6",
"1.5.6",
"v1.5.5",
"1.5.5",
"v1.5.4",
"1.5.4",
"v1.5.3",
"1.5.3",
"v1.5.2.1",
"1.5.2.1",
"v1.5.2",
"1.5.2",
"v1.5.1",
"1.5.1",
"v1.5",
"1.5",
"v1.4.4",
"1.4.4",
"v1.4.3",
"1.4.3",
"v1.4.2",
"1.4.2",
"v1.4.1",
"1.4.1",
"v1.4",
"1.4",
"v1.3.2",
"1.3.2",
"v1.3.1",
"1.3.1",
"v1.3",
"1.3",
"v1.2.4",
"1.2.4",
"v1.2.3",
"1.2.3",
"v1.2.2",
"1.2.2",
"v1.2.1",
"1.2.1",
"v1.2",
"1.2",
"v1.1.3",
"1.1.3",
"v1.1.2",
"1.1.2",
"v1.1.1",
"1.1.1",
"v1.1",
"1.1",
"v1.0.3",
"1.0.3",
"v1.0.2",
"1.0.2",
"v1.0.1",
"1.0.1",
"v1.0",
"1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-9168.json"
}
}
],
"modified": "2026-10-24T10:30:45.678678307Z",
"provider": "osv",
"references": [
"https://woocommerce.wordpress.com/2019/02/20/woocommerce-3-5-5-security-fix-release/"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2019-9168",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 436165,
"published_at": "2019-02-26T00:29:00.19+00:00"
}