Apollo Router Improperly Enforces Renamed Access Control Directives
Apollo Router Core is a configurable Rust graph router written to run a federated supergraph using Apollo Federation 2. Versions 1.61.12-rc.0 and below and 2.8.1-rc.0 allow unauthorized access to protected data through schema elements with access control directives (@authenticated, @requiresScopes, and @policy) that were renamed via @link imports. Router did not enforce renamed access control directives on schema elements (e.g. fields and types), allowing queries to bypass those element-level access controls. This issue is fixed in versions 1.61.12 and 2.8.1.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-64347
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 01:11 UTC · Revision 1
Source evidence
Apollo Router Improperly Enforces Renamed Access Control Directives
core-osv · Original sourcePublished 7 Nov 2025, 17:47 UTC
Apollo Router Core is a configurable Rust graph router written to run a federated supergraph using Apollo Federation 2. Versions 1.61.12-rc.0 and below and 2.8.1-rc.0 allow unauthorized access to protected data through schema elements with access control directives (@authenticated, @requiresScopes, and @policy) that were renamed via @link imports. Router did not enforce renamed access control directives on schema elements (e.g. fields and types), allowing queries to bypass those element-level access controls. This issue is fixed in versions 1.61.12 and 2.8.1.
osv:CVE-2025-64347
Complete source record
{
"id": "4d53b712f935da9cb96cc0e044bb2452e94047f5a58c73b4228da94f36425420",
"url": "https://osv.dev/vulnerability/CVE-2025-64347",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apollo Router Improperly Enforces Renamed Access Control Directives",
"summary": "Apollo Router Core is a configurable Rust graph router written to run a federated supergraph using Apollo Federation 2. Versions 1.61.12-rc.0 and below and 2.8.1-rc.0 allow unauthorized access to protected data through schema elements with access control directives (@authenticated, @requiresScopes, and @policy) that were renamed via @link imports. Router did not enforce renamed access control directives on schema elements (e.g. fields and types), allowing queries to bypass those element-level access controls. This issue is fixed in versions 1.61.12 and 2.8.1.",
"evidence": "osv:CVE-2025-64347",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2025-64347",
"aliases": [
"CVE-2025-64347",
"GHSA-g8jh-vg5j-4h3f"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apollographql/router",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "12517bebc84259dc2dd39d33d229358026e174f9"
},
{
"introduced": "827cfa979e45f636a5a68fcaecf3864ba7534d9d"
},
{
"fixed": "efb0dcbfe8d668e3aeb1ade1513072d449128dc4"
},
{
"fixed": "78e4b20a2fc26cc5f141aa47992ed85375266a2b"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "1.61.12"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"introduced": "2.8.1-rc.0"
},
{
"fixed": "2.8.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "78e4b20a2fc26cc5f141aa47992ed85375266a2b"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v1.61.12-rc.0",
"v2.8.1-rc.0",
"v2.8.0",
"v1.59.1",
"v1.58.1",
"v1.59.0",
"v1.58.0",
"v1.57.1",
"v1.57.0",
"v1.56.0",
"v1.55.0",
"v1.54.0",
"v1.53.0",
"v1.52.0",
"v1.51.0",
"v1.50.0",
"v1.49.1",
"v1.49.0",
"v1.48.1",
"v1.48.0",
"v1.47.0",
"v1.46.0",
"v1.45.1",
"v1.45.0",
"v1.44.0",
"v1.43.2",
"v1.43.1",
"v1.43.0",
"v1.20.0",
"v1.42.0",
"v1.41.1",
"v1.41.0",
"v1.40.1",
"v1.40.0",
"v1.39.1",
"v1.39.0",
"v1.38.0",
"v1.37.0",
"v1.36.0",
"v1.35.0",
"v1.34.1",
"v1.34.0",
"v1.33.2",
"v1.33.1",
"v1.33.0",
"v1.32.0",
"v1.31.0",
"v1.30.1",
"v1.30.0",
"v1.29.1",
"v1.29.0",
"v1.28.1",
"v1.28.0",
"v1.27.0",
"v1.26.0",
"v1.25.0",
"v1.24.0",
"v1.23.0",
"v1.22.0",
"v1.21.0",
"v1.19.1",
"v1.19.0",
"v1.18.1",
"v1.18.0",
"v1.17.0",
"v1.15.1",
"v1.15.0",
"v1.14.0",
"v1.13.2",
"v1.13.1",
"v1.13.0",
"v1.12.1",
"v1.12.0",
"v1.11.0",
"v1.10.3",
"v1.10.2",
"v1.10.1",
"v1.10.0",
"v1.9.0",
"v1.8.0",
"v1.7.0",
"v1.6.0",
"v1.5.0",
"v1.4.0",
"v1.3.0",
"v1.2.1",
"v1.2.0",
"v1.1.0",
"v1.0.0",
"v1.0.0-rc.2",
"v1.0.0-rc.1",
"v1.0.0-rc.0",
"v1.0.0-alpha.3",
"v1.0.0-alpha.2",
"v1.0.0-alpha.1",
"v1.0.0-alpha.0",
"v0.16.0",
"v0.15.1",
"v0.15.0",
"v0.14.0",
"v0.12.0",
"v0.11.0",
"v0.10.0",
"v0.9.5",
"v0.9.4",
"v0.9.3",
"v0.9.2",
"v0.9.1",
"v0.9.0",
"v0.9.0-rc.0",
"v0.1.0-preview.7",
"v0.1.0-preview.6",
"v0.1.0-preview.5",
"v0.1.0-preview.4",
"v0.1.0-preview.3",
"v0.1.0-preview.2",
"v0.1.0-preview.1",
"v0.1.0-preview.0",
"v0.1.0-alpha.10",
"v0.1.0-alpha.9",
"v0.1.0-alpha.8",
"v0.1.0-alpha.7",
"v0.1.0-alpha.6",
"v0.1.0-alpha.2",
"v0.1.0-alpha.1",
"v0.1.0-alpha.0",
"v0.1.0-prealpha.5",
"v0.1.0-prealpha.4"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-64347.json"
}
}
],
"modified": "2026-10-28T02:30:25.087106645Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/64xxx/CVE-2025-64347.json",
"https://github.com/apollographql/router/security/advisories/GHSA-g8jh-vg5j-4h3f",
"https://nvd.nist.gov/vuln/detail/CVE-2025-64347",
"https://github.com/apollographql/router/commit/78e4b20a2fc26cc5f141aa47992ed85375266a2b"
],
"provider_metadata": {
"cwe_ids": [
"CWE-284"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/64xxx/CVE-2025-64347.json"
}
},
"related_cves": [
{
"value": "CVE-2025-64347",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 491451,
"published_at": "2025-11-07T17:47:28.36+00:00"
}