Skip to content
Heist/ feed
Back to feed
Critical

MCP Inspector proxy server lacks authentication between the Inspector client and proxy

Type: advisorySources: OSV

The MCP inspector is a developer tool for testing and debugging MCP servers. Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-49596
Confirmed fixed CVEs
Not specified
Updated in this feed
8 Nov 2026, 03:18 UTC · Revision 1

Source evidence

MCP Inspector proxy server lacks authentication between the Inspector client and proxy

core-osv · Original source

Published 13 Jun 2025, 20:11 UTC

The MCP inspector is a developer tool for testing and debugging MCP servers. Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.

osv:CVE-2025-49596
Complete source record
{
  "id": "a90d1438cbe3decb89803e2bf333303cfb9a690b5acfc830d1db078f4dba296b",
  "url": "https://osv.dev/vulnerability/CVE-2025-49596",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "MCP Inspector proxy server lacks authentication between the Inspector client and proxy",
    "summary": "The MCP inspector is a developer tool for testing and debugging MCP servers. Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.",
    "evidence": "osv:CVE-2025-49596",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2025-49596",
      "aliases": [
        "CVE-2025-49596",
        "GHSA-7f8r-222p-6f5g"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/modelcontextprotocol/inspector",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "65910ebc4c1dd136d09dfd96c688f9981b42e54a"
                },
                {
                  "fixed": "50df0e1ec488f3983740b4d28d2a968f12eb8979"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "0.14.1"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "fixed": "50df0e1ec488f3983740b4d28d2a968f12eb8979"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "0.14.0",
            "0.13.0",
            "0.12.0",
            "0.11.0-amended",
            "0.11.0",
            "0.10.2",
            "0.9.0",
            "0.8.2",
            "0.8.1-hotfix",
            "0.8.1",
            "0.8.0",
            "0.7.0",
            "0.6.0",
            "0.5.1",
            "0.4.1",
            "0.4.0",
            "0.3.0",
            "0.2.7",
            "0.2.6",
            "0.2.5",
            "0.2.4",
            "0.2.3",
            "0.2.2",
            "0.2.1",
            "0.2.0",
            "0.1.0",
            "0.0.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-49596.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:53.310261618Z",
      "provider": "osv",
      "references": [
        "https://thenewstack.io/mcp-vulnerability-exposes-the-ai-untrusted-code-crisis",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/49xxx/CVE-2025-49596.json",
        "https://github.com/modelcontextprotocol/inspector/security/advisories/GHSA-7f8r-222p-6f5g",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-49596",
        "https://github.com/modelcontextprotocol/inspector/commit/50df0e1ec488f3983740b4d28d2a968f12eb8979",
        "https://www.oligo.security/blog/critical-rce-vulnerability-in-anthropic-mcp-inspector-cve-2025-49596"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-306"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/49xxx/CVE-2025-49596.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-49596",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 522147,
  "published_at": "2025-06-13T20:11:40.453+00:00"
}