Critical
Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin
Type: advisorySources: OSV
Improper validation of script alert plugin parameters in Apache DolphinScheduler to avoid remote command execution vulnerability. This issue affects Apache DolphinScheduler version 3.0.1 and prior versions; version 3.1.0 and prior versions. This attack can be performed only by authenticated users which can login to DS.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-45875
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 17:10 UTC · Revision 1
Source evidence
Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin
core-osv · Original sourcePublished 4 Jan 2023, 14:57 UTC
Improper validation of script alert plugin parameters in Apache DolphinScheduler to avoid remote command execution vulnerability. This issue affects Apache DolphinScheduler version 3.0.1 and prior versions; version 3.1.0 and prior versions. This attack can be performed only by authenticated users which can login to DS.
osv:CVE-2022-45875
Complete source record
{
"id": "90cee2ac6bb12a7f9069c170c3bba00346ee658936e3b24493de38b11cda5aa7",
"url": "https://osv.dev/vulnerability/CVE-2022-45875",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin",
"summary": "Improper validation of script alert plugin parameters in Apache DolphinScheduler to avoid remote command execution vulnerability. This issue affects Apache DolphinScheduler version 3.0.1 and prior versions; version 3.1.0 and prior versions. This attack can be performed only by authenticated users which can login to DS.",
"evidence": "osv:CVE-2022-45875",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2022-45875",
"aliases": [
"CVE-2022-45875",
"GHSA-3xh5-8hvq-rc8x",
"PYSEC-2023-4"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/dolphinscheduler",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "d2ba3d4cfb3ab9f252340aa603ea036baa52f88c"
},
{
"introduced": "ae33ba594754425a2ac72100450adffd3b5e3971"
},
{
"last_affected": "ae33ba594754425a2ac72100450adffd3b5e3971"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:dolphinscheduler:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.0.2"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:apache:dolphinscheduler:3.1.0:*:*:*:*:*:*:*",
"range": [
{
"introduced": "3.1.0"
},
{
"last_affected": "3.1.0"
}
],
"source": "CPE_STRING"
}
]
}
}
],
"versions": [
"3.1.0",
"3.0.1",
"3.0.0",
"3.0.0-beta-2",
"3.0.0-beta-1",
"1.1.0-preview"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-45875.json"
}
}
],
"modified": "2026-10-28T02:30:51.142503563Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/45xxx/CVE-2022-45875.json",
"https://lists.apache.org/thread/r0wqzkjsoq17j6ww381kmpx3jjp9hb6r",
"https://nvd.nist.gov/vuln/detail/CVE-2022-45875"
],
"provider_metadata": {
"cwe_ids": [
"CWE-20"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "3.0"
},
{
"last_affected": "3.0.1"
},
{
"introduced": "3.1"
},
{
"last_affected": "3.1.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/45xxx/CVE-2022-45875.json"
}
},
"related_cves": [
{
"value": "CVE-2022-45875",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 519950,
"published_at": "2023-01-04T14:57:45.334+00:00"
}