libyaml-perl — security advisory
YAML versions before 1.30 for Perl allow a loaded document to trigger the DESTROY method of arbitrary classes. A perl/hash:Class tag blesses a hash into the class it names. The document supplies the object's fields, and Perl calls DESTROY when it goes out of scope. What DESTROY does depends on the classes the process has loaded. With File::Temp::Dir from core Perl, it can delete a directory tree the document names.
- Products
- libyaml-perl
- Affected versions
- 1.13-1, 1.15-1, 1.21-1, 1.24-1
- Fixed versions
- 1.15-1ubuntu0.1~esm1, 1.24-1ubuntu0.1~esm1
- CVEs
- CVE-2017-20285
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 12:12 UTC · Revision 1
Source evidence
YAML versions before 1.30 for Perl allow a loaded document to trigger the DESTROY method of arbitrary classes. A perl/hash:Class tag blesses a hash into the class it names. The document supplies the object's fields, and Perl calls DESTROY when it goes out of scope. What DESTROY does depends on the classes the process has loaded. With File::Temp::Dir from core Perl, it can delete a directory tree the document names.
osv:UBUNTU-CVE-2017-20285
libyaml-perl
Fixed versions: 1.15-1ubuntu0.1~esm1
libyaml-perl
Fixed versions: 1.24-1ubuntu0.1~esm1
Complete source record
{
"id": "23a843d42b9cf7a38c4adbe9ec0de1c3f7a8c9cc54d52a31227dab0d1ac80835",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2017-20285",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2017-20285",
"summary": "YAML versions before 1.30 for Perl allow a loaded document to trigger the DESTROY method of arbitrary classes. A perl/hash:Class tag blesses a hash into the class it names. The document supplies the object's fields, and Perl calls DESTROY when it goes out of scope. What DESTROY does depends on the classes the process has loaded. With File::Temp::Dir from core Perl, it can delete a directory tree the document names.",
"evidence": "osv:UBUNTU-CVE-2017-20285",
"products": [
{
"name": {
"value": "libyaml-perl",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.15-1ubuntu0.1~esm1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "1.13-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.15-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "libyaml-perl",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.24-1ubuntu0.1~esm1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "1.21-1",
"evidence": "/affected/1/versions"
},
{
"value": "1.24-1",
"evidence": "/affected/1/versions"
}
]
}
],
"severity": "critical",
"structured": {
"id": "UBUNTU-CVE-2017-20285",
"aliases": [
"UBUNTU-CVE-2017-20285"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.15-1ubuntu0.1~esm1"
}
]
}
],
"package": {
"name": "libyaml-perl",
"purl": "pkg:deb/ubuntu/libyaml-perl?arch=source&distro=esm-infra-legacy%2Fxenial",
"ecosystem": "Ubuntu:Pro:16.04:LTS"
},
"versions": [
"1.13-1",
"1.15-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2017/UBUNTU-CVE-2017-20285.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libyaml-perl",
"binary_version": "1.15-1ubuntu0.1~esm1"
}
],
"availability": "Available with Ubuntu Pro with Legacy support add-on: https://ubuntu.com/pro"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.24-1ubuntu0.1~esm1"
}
]
}
],
"package": {
"name": "libyaml-perl",
"purl": "pkg:deb/ubuntu/libyaml-perl?arch=source&distro=esm-infra%2Fbionic",
"ecosystem": "Ubuntu:Pro:18.04:LTS"
},
"versions": [
"1.21-1",
"1.24-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2017/UBUNTU-CVE-2017-20285.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libyaml-perl",
"binary_version": "1.24-1ubuntu0.1~esm1"
}
],
"availability": "Available with Ubuntu Pro (Infra-only): https://ubuntu.com/pro"
}
}
],
"modified": "2026-10-14T11:45:06.682164771Z",
"provider": "osv",
"upstream": [
"CVE-2017-20285"
],
"references": [
"https://ubuntu.com/security/CVE-2017-20285",
"https://www.cve.org/CVERecord?id=CVE-2017-20285",
"https://www.openwall.com/lists/oss-security/2026/10/05/8",
"https://blogs.perl.org/users/tinita/2020/01/making-yamlpm-yamlsyck-and-yamlxs-safer-by-default.html",
"https://ubuntu.com/security/notices/USN-8925-1"
]
},
"related_cves": [
{
"value": "CVE-2017-20285",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 316280,
"published_at": "2026-10-05T07:16:00+00:00"
}