phpldapadmin — security advisory
Multiple cross-site scripting (XSS) vulnerabilities in phpLDAPadmin 0.9.8 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) dn parameter in (a) compare_form.php, (b) copy_form.php, (c) rename_form.php, (d) template_engine.php, and (e) delete_form.php; (2) scope parameter in (f) search.php; and (3) Container DN, (4) Machine Name, and (5) UID Number fields in (g) template_engine.php.
- Products
- phpldapadmin
- Affected versions
- Not specified
- Fixed versions
- 0.9.8.3-1
- CVEs
- CVE-2006-2016
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 20:09 UTC · Revision 1
Source evidence
Multiple cross-site scripting (XSS) vulnerabilities in phpLDAPadmin 0.9.8 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) dn parameter in (a) compare_form.php, (b) copy_form.php, (c) rename_form.php, (d) template_engine.php, and (e) delete_form.php; (2) scope parameter in (f) search.php; and (3) Container DN, (4) Machine Name, and (5) UID Number fields in (g) template_engine.php.
osv:DEBIAN-CVE-2006-2016
phpldapadmin
Fixed versions: 0.9.8.3-1
phpldapadmin
Fixed versions: 0.9.8.3-1
phpldapadmin
Fixed versions: 0.9.8.3-1
Complete source record
{
"id": "9d0287cdb9596529fe42c0ab8f50f7d85bf9f5f2fc777ead39cb7d0ba16ac583",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2006-2016",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2006-2016",
"summary": "Multiple cross-site scripting (XSS) vulnerabilities in phpLDAPadmin 0.9.8 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) dn parameter in (a) compare_form.php, (b) copy_form.php, (c) rename_form.php, (d) template_engine.php, and (e) delete_form.php; (2) scope parameter in (f) search.php; and (3) Container DN, (4) Machine Name, and (5) UID Number fields in (g) template_engine.php.",
"evidence": "osv:DEBIAN-CVE-2006-2016",
"products": [
{
"name": {
"value": "phpldapadmin",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.9.8.3-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "phpldapadmin",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.9.8.3-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "phpldapadmin",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.9.8.3-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2006-2016",
"aliases": [
"DEBIAN-CVE-2006-2016"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.9.8.3-1"
}
]
}
],
"package": {
"name": "phpldapadmin",
"purl": "pkg:deb/debian/phpldapadmin?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-2016.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.9.8.3-1"
}
]
}
],
"package": {
"name": "phpldapadmin",
"purl": "pkg:deb/debian/phpldapadmin?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-2016.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.9.8.3-1"
}
]
}
],
"package": {
"name": "phpldapadmin",
"purl": "pkg:deb/debian/phpldapadmin?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-2016.json"
},
"ecosystem_specific": {
"urgency": "low"
}
}
],
"modified": "2026-10-22T23:47:19.657472505Z",
"provider": "osv",
"upstream": [
"CVE-2006-2016"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2006-2016"
]
},
"related_cves": [
{
"value": "CVE-2006-2016",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 410223,
"published_at": "2006-04-25T12:50:00+00:00"
}