CKEditor: Cross-site scripting (XSS) in the engine package
CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. From 29.0.0 until 47.7.4 and 48.5.1, specially crafted markup can trigger cross-site scripting when General HTML Support is enabled and specifically configured to allow object content. Processing that content can execute attacker-controlled JavaScript in a browser context isolated from the origin of the application embedding the editor. This issue is fixed in versions 47.7.4 and 48.5.1.
- Products
- ckeditor5
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-116687
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 15:41 UTC · Revision 1
Source evidence
CKEditor: Cross-site scripting (XSS) in the engine package
core-cve · Original sourcePublished 27 Oct 2026, 19:33 UTC
CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. From 29.0.0 until 47.7.4 and 48.5.1, specially crafted markup can trigger cross-site scripting when General HTML Support is enabled and specifically configured to allow object content. Processing that content can execute attacker-controlled JavaScript in a browser context isolated from the origin of the application embedding the editor. This issue is fixed in versions 47.7.4 and 48.5.1.
cve:CVE-2026-116687
ckeditor5
Fixed versions: Not specified
Complete source record
{
"id": "8b2211073c03aaa10e270f27c7eb3dc7815b233bd8c7dfa11ef8e41ab3e8023b",
"url": "https://www.cve.org/CVERecord?id=CVE-2026-116687",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CKEditor: Cross-site scripting (XSS) in the engine package",
"summary": "CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. From 29.0.0 until 47.7.4 and 48.5.1, specially crafted markup can trigger cross-site scripting when General HTML Support is enabled and specifically configured to allow object content. Processing that content can execute attacker-controlled JavaScript in a browser context isolated from the origin of the application embedding the editor. This issue is fixed in versions 47.7.4 and 48.5.1.",
"evidence": "cve:CVE-2026-116687",
"products": [
{
"name": {
"value": "ckeditor5",
"evidence": "/containers/cna/affected/0/product"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": []
}
],
"severity": "low",
"structured": {
"id": "CVE-2026-116687",
"aliases": [
"CVE-2026-116687"
],
"metrics": [
{
"cvssV3_1": {
"scope": "UNCHANGED",
"version": "3.1",
"baseScore": 3.1,
"attackVector": "NETWORK",
"baseSeverity": "LOW",
"vectorString": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N",
"integrityImpact": "LOW",
"userInteraction": "NONE",
"attackComplexity": "HIGH",
"availabilityImpact": "NONE",
"privilegesRequired": "LOW",
"confidentialityImpact": "NONE"
}
}
],
"affected": [
{
"vendor": "ckeditor",
"product": "ckeditor5",
"versions": [
{
"status": "affected",
"version": ">= 29.0.0, < 47.7.4"
},
{
"status": "affected",
"version": ">= 48.0.0, < 48.5.1"
}
]
}
],
"modified": "2026-10-27T19:33:11.074Z",
"provider": "cve",
"references": [
"https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-v6mg-96c6-gmpq",
"https://github.com/ckeditor/ckeditor5/commit/4d9c5bb34f63cd956d15ccafbe584e14280c86a0",
"https://github.com/ckeditor/ckeditor5/commit/a750e38635db6a18c5b11599c09f4fd702850423",
"https://github.com/ckeditor/ckeditor5/releases/tag/v47.7.4",
"https://github.com/ckeditor/ckeditor5/releases/tag/v48.5.1"
],
"provider_metadata": {
"cna": {
"orgId": "a0819718-46f1-4df5-94e2-005712e83aaa",
"shortName": "GitHub_M",
"dateUpdated": "2026-10-27T19:33:11.074Z"
}
}
},
"related_cves": [
{
"value": "CVE-2026-116687",
"evidence": "/cveMetadata/cveId"
}
],
"security_relevant": true,
"severity_evidence": "/containers/cna/metrics"
},
"source_id": "core-cve",
"document_id": 398113,
"published_at": "2026-10-27T19:33:11.074+00:00"
}