Sulu grants access to pages regardless of role permissions
Sulu is a PHP content management system. Starting in verson 2.2.0 and prior to version 2.4.17 and 2.5.13, access to pages is granted regardless of role permissions for webspaces which have a security system configured and permission check enabled. Webspaces without do not have this issue. The problem is patched in versions 2.4.17 and 2.5.13. Some workarounds are available. One may apply the patch to `vendor/symfony/security-http/HttpUtils.php` manually or avoid installing `symfony/security-http` versions greater equal than `v5.4.30` or `v6.3.6`.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-27915
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 05:45 UTC · Revision 1
Source evidence
Sulu grants access to pages regardless of role permissions
core-osv · Original sourcePublished 6 Mar 2024, 19:33 UTC
Sulu is a PHP content management system. Starting in verson 2.2.0 and prior to version 2.4.17 and 2.5.13, access to pages is granted regardless of role permissions for webspaces which have a security system configured and permission check enabled. Webspaces without do not have this issue. The problem is patched in versions 2.4.17 and 2.5.13. Some workarounds are available. One may apply the patch to `vendor/symfony/security-http/HttpUtils.php` manually or avoid installing `symfony/security-http` versions greater equal than `v5.4.30` or `v6.3.6`.
osv:CVE-2024-27915
Complete source record
{
"id": "b6662a64b95c44a96f2ae96e5db513d18b49ac217fe6485424df299dae77350c",
"url": "https://osv.dev/vulnerability/CVE-2024-27915",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Sulu grants access to pages regardless of role permissions",
"summary": "Sulu is a PHP content management system. Starting in verson 2.2.0 and prior to version 2.4.17 and 2.5.13, access to pages is granted regardless of role permissions for webspaces which have a security system configured and permission check enabled. Webspaces without do not have this issue. The problem is patched in versions 2.4.17 and 2.5.13. Some workarounds are available. One may apply the patch to `vendor/symfony/security-http/HttpUtils.php` manually or avoid installing `symfony/security-http` versions greater equal than `v5.4.30` or `v6.3.6`.",
"evidence": "osv:CVE-2024-27915",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-27915",
"aliases": [
"CVE-2024-27915",
"GHSA-jr83-m233-gg6p"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/sulu/sulu",
"type": "GIT",
"events": [
{
"introduced": "2dac9dd6930146186301ff9f6b5a7d84921a8dc2"
},
{
"fixed": "c3d6ec4d8cff9430ac93bc3b27e3b9328ce89893"
},
{
"introduced": "dc0de2a6a5d26771265ef052f83a5a9ac0894662"
},
{
"fixed": "62d7b1b26a5927c4c063fd00ab466bf8f16b48f7"
},
{
"fixed": "ec9c3f99e15336dc4f6877f512300f231c17c6da"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:sulu:sulu:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.2.0"
},
{
"fixed": "2.4.17"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:sulu:sulu:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.5.0"
},
{
"fixed": "2.5.13"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "ec9c3f99e15336dc4f6877f512300f231c17c6da"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"2.4.16",
"2.5.12",
"2.5.11",
"2.4.15",
"2.4.14",
"2.5.10",
"2.5.9",
"2.4.13",
"2.4.12",
"2.5.8",
"2.5.7",
"2.4.11",
"2.5.6",
"2.4.10",
"2.4.9",
"2.5.5",
"2.5.4",
"2.4.8",
"2.5.3",
"2.4.7",
"2.4.6",
"2.5.2",
"2.5.1",
"2.4.5",
"2.4.4",
"2.5.0",
"2.4.3",
"2.4.2",
"2.4.1",
"2.4.0",
"2.4.0-RC1",
"2.3.1",
"2.3.0",
"2.3.0-RC2",
"2.3.0-RC1",
"2.2.1",
"2.2.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-27915.json"
}
}
],
"modified": "2026-10-28T02:30:26.208690571Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/27xxx/CVE-2024-27915.json",
"https://github.com/sulu/sulu/security/advisories/GHSA-jr83-m233-gg6p",
"https://nvd.nist.gov/vuln/detail/CVE-2024-27915",
"https://github.com/sulu/sulu/commit/ec9c3f99e15336dc4f6877f512300f231c17c6da"
],
"provider_metadata": {
"cwe_ids": [
"CWE-863"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/27xxx/CVE-2024-27915.json"
}
},
"related_cves": [
{
"value": "CVE-2024-27915",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 492819,
"published_at": "2024-03-06T19:33:11.798+00:00"
}