xrdp — security advisory
xrdp is an open source RDP server. Versions through 0.10.5 have a heap-based buffer overflow in the EGFX (graphics dynamic virtual channel) implementation due to insufficient validation of client-controlled size parameters, allowing an out-of-bounds write via crafted PDUs. Pre-authentication exploitation can crash the process, while post-authentication exploitation may achieve remote code execution. This issue has been fixed in version 0.10.6. If users are unable to immediately update, they should run xrdp as a non-privileged user (default since 0.10.2) to limit the impact of successful exploitation.
- Products
- xrdp
- Affected versions
- 0.10.1-3.1, 0.10.1-3.1+deb13u1, 0.10.1-4, 0.10.1-4.1, 0.10.2-1, 0.10.2-2, 0.10.4.1-1, 0.10.4.1-2, 0.10.5-1, 0.10.5-2, 0.10.5-3, 0.10.5-4, 0.10.5-5
- Fixed versions
- 0.10.1-3.1+deb13u2, 0.10.6-1
- CVEs
- CVE-2026-35512
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 17:51 UTC · Revision 2
Source evidence
xrdp is an open source RDP server. Versions through 0.10.5 have a heap-based buffer overflow in the EGFX (graphics dynamic virtual channel) implementation due to insufficient validation of client-controlled size parameters, allowing an out-of-bounds write via crafted PDUs. Pre-authentication exploitation can crash the process, while post-authentication exploitation may achieve remote code execution. This issue has been fixed in version 0.10.6. If users are unable to immediately update, they should run xrdp as a non-privileged user (default since 0.10.2) to limit the impact of successful exploitation.
osv:DEBIAN-CVE-2026-35512
xrdp
Fixed versions: 0.10.1-3.1+deb13u2
xrdp
Fixed versions: 0.10.6-1
Complete source record
{
"id": "2eb8a1fdf2af82fece8f506c127f6b772e7b845612c08b2431d9bfd9500fd3ee",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-35512",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-35512",
"summary": "xrdp is an open source RDP server. Versions through 0.10.5 have a heap-based buffer overflow in the EGFX (graphics dynamic virtual channel) implementation due to insufficient validation of client-controlled size parameters, allowing an out-of-bounds write via crafted PDUs. Pre-authentication exploitation can crash the process, while post-authentication exploitation may achieve remote code execution. This issue has been fixed in version 0.10.6. If users are unable to immediately update, they should run xrdp as a non-privileged user (default since 0.10.2) to limit the impact of successful exploitation.",
"evidence": "osv:DEBIAN-CVE-2026-35512",
"products": [
{
"name": {
"value": "xrdp",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.10.1-3.1+deb13u2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "0.10.1-3.1",
"evidence": "/affected/0/versions"
},
{
"value": "0.10.1-3.1+deb13u1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "xrdp",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.10.6-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "0.10.1-3.1",
"evidence": "/affected/1/versions"
},
{
"value": "0.10.1-4",
"evidence": "/affected/1/versions"
},
{
"value": "0.10.1-4.1",
"evidence": "/affected/1/versions"
},
{
"value": "0.10.2-1",
"evidence": "/affected/1/versions"
},
{
"value": "0.10.2-2",
"evidence": "/affected/1/versions"
},
{
"value": "0.10.4.1-1",
"evidence": "/affected/1/versions"
},
{
"value": "0.10.4.1-2",
"evidence": "/affected/1/versions"
},
{
"value": "0.10.5-1",
"evidence": "/affected/1/versions"
},
{
"value": "0.10.5-2",
"evidence": "/affected/1/versions"
},
{
"value": "0.10.5-3",
"evidence": "/affected/1/versions"
},
{
"value": "0.10.5-4",
"evidence": "/affected/1/versions"
},
{
"value": "0.10.5-5",
"evidence": "/affected/1/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2026-35512",
"aliases": [
"DEBIAN-CVE-2026-35512"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.10.1-3.1+deb13u2"
}
]
}
],
"package": {
"name": "xrdp",
"purl": "pkg:deb/debian/xrdp?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"0.10.1-3.1",
"0.10.1-3.1+deb13u1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-35512.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.10.6-1"
}
]
}
],
"package": {
"name": "xrdp",
"purl": "pkg:deb/debian/xrdp?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"0.10.1-3.1",
"0.10.1-4",
"0.10.1-4.1",
"0.10.2-1",
"0.10.2-2",
"0.10.4.1-1",
"0.10.4.1-2",
"0.10.5-1",
"0.10.5-2",
"0.10.5-3",
"0.10.5-4",
"0.10.5-5"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-35512.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-27T09:47:42.631260722Z",
"provider": "osv",
"upstream": [
"CVE-2026-35512"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-35512"
]
},
"related_cves": [
{
"value": "CVE-2026-35512",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 461371,
"published_at": "2026-04-17T21:16:33.297+00:00"
}