node-min — security advisory
Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to Remote Code Execution, XSS, Application crashes due to missing input validation of host names returned by Domain Name Servers in Node.js dns library which can lead to output of wrong hostnames (leading to Domain Hijacking) and injection vulnerabilities in applications using the library.
- Products
- node-min
- Affected versions
- Not specified
- Fixed versions
- 12.12.1, 12.22.5, 14.14.1, 14.17.5, 16.6.2
- CVEs
- CVE-2021-22931
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 19:54 UTC · Revision 1
Source evidence
Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to Remote Code Execution, XSS, Application crashes due to missing input validation of host names returned by Domain Name Servers in Node.js dns library which can lead to output of wrong hostnames (leading to Domain Hijacking) and injection vulnerabilities in applications using the library.
osv:BIT-node-min-2021-22931
node-min
Fixed versions: 12.12.1, 12.22.5, 14.14.1, 14.17.5, 16.6.2
Complete source record
{
"id": "1ab3dd165b159b94af601fc10ceae87e0766820edd81835b796952f470ad6230",
"url": "https://osv.dev/vulnerability/BIT-node-min-2021-22931",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "BIT-node-min-2021-22931",
"summary": "Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to Remote Code Execution, XSS, Application crashes due to missing input validation of host names returned by Domain Name Servers in Node.js dns library which can lead to output of wrong hostnames (leading to Domain Hijacking) and injection vulnerabilities in applications using the library.",
"evidence": "osv:BIT-node-min-2021-22931",
"products": [
{
"name": {
"value": "node-min",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "12.12.1",
"evidence": "/affected/0/ranges"
},
{
"value": "12.22.5",
"evidence": "/affected/0/ranges"
},
{
"value": "14.14.1",
"evidence": "/affected/0/ranges"
},
{
"value": "14.17.5",
"evidence": "/affected/0/ranges"
},
{
"value": "16.6.2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "critical",
"structured": {
"id": "BIT-node-min-2021-22931",
"aliases": [
"BIT-node-2021-22931",
"BIT-node-min-2021-22931",
"CVE-2021-22931"
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "12.0.0"
},
{
"fixed": "12.12.1"
},
{
"introduced": "12.13.0"
},
{
"fixed": "12.22.5"
},
{
"introduced": "14.0.0"
},
{
"fixed": "14.14.1"
},
{
"introduced": "14.15.0"
},
{
"fixed": "14.17.5"
},
{
"introduced": "16.0.0"
},
{
"fixed": "16.6.2"
}
]
}
],
"package": {
"name": "node-min",
"purl": "pkg:bitnami/node-min",
"ecosystem": "Bitnami"
},
"severity": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"database_specific": {
"source": "https://github.com/bitnami/vulndb/tree/main/data/node-min/BIT-node-min-2021-22931.json"
}
}
],
"modified": "2026-10-16T09:45:28.567319916Z",
"provider": "osv",
"references": [
"https://hackerone.com/reports/1178337",
"https://nodejs.org/en/blog/vulnerability/aug-2021-security-releases/",
"https://security.gentoo.org/glsa/202401-02",
"https://security.netapp.com/advisory/ntap-20210923-0001/",
"https://security.netapp.com/advisory/ntap-20211022-0003/",
"https://www.oracle.com/security-alerts/cpujan2022.html",
"https://www.oracle.com/security-alerts/cpujul2022.html",
"https://www.oracle.com/security-alerts/cpuoct2021.html",
"https://nvd.nist.gov/vuln/detail/CVE-2021-22931"
],
"provider_metadata": {
"cpes": [
"cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:*",
"cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:*"
],
"severity": "Critical"
}
},
"related_cves": [
{
"value": "CVE-2021-22931",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 338460,
"published_at": "2024-12-16T14:05:15.223+00:00"
}