lxd — security advisory
A privilege escalation vulnerability exists in LXD from 6.0 before 6.9, 5.21.0 before 5.21.5, and 5.0.0 before 5.0.7 regarding the handling of project-restriction policies during snapshot restoration.. An authenticated project operator in a restricted multi-tenant environment can bypass policy restrictions by importing a maliciously crafted instance backup containing restricted configuration keys within a snapshot. When the snapshot is restored, these restricted keys are applied to the live instance without policy validation. Starting the modified instance grants the operator unauthorized host root access.
- Products
- lxd
- Affected versions
- 5.0.2+git20231211.1364ae4-1, 5.0.2+git20231211.1364ae4-2, 5.0.2+git20231211.1364ae4-3, 5.0.2+git20231211.1364ae4-4, 5.0.2+git20231211.1364ae4-5, 5.0.2+git20231211.1364ae4-6, 5.0.2+git20231211.1364ae4-7, 5.0.2+git20231211.1364ae4-8, 5.0.2+git20231211.1364ae4-9, 5.0.2+git20231211.1364ae4-9+deb13u1, 5.0.2+git20231211.1364ae4-9+deb13u2, 5.0.2+git20231211.1364ae4-9+deb13u3, 5.0.2+git20231211.1364ae4-9+deb13u4, 5.0.2+git20231211.1364ae4-9+deb13u5, 5.0.2+git20231211.1364ae4-9+deb13u6, 5.0.2-5, 5.0.2-5+deb12u1, 5.0.2-5+deb12u2, 5.0.2-5+deb12u3, 5.0.2-5+deb12u4, 5.0.2-5+deb12u5, 5.0.2-5+deb12u6, 5.0.2-6
- Fixed versions
- 5.0.2+git20231211.1364ae4-9+deb13u7
- CVEs
- CVE-2026-9640
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 12:18 UTC · Revision 2
Source evidence
A privilege escalation vulnerability exists in LXD from 6.0 before 6.9, 5.21.0 before 5.21.5, and 5.0.0 before 5.0.7 regarding the handling of project-restriction policies during snapshot restoration.. An authenticated project operator in a restricted multi-tenant environment can bypass policy restrictions by importing a maliciously crafted instance backup containing restricted configuration keys within a snapshot. When the snapshot is restored, these restricted keys are applied to the live instance without policy validation. Starting the modified instance grants the operator unauthorized host root access.
osv:DEBIAN-CVE-2026-9640
lxd
Fixed versions: Not specified
lxd
Fixed versions: 5.0.2+git20231211.1364ae4-9+deb13u7
Complete source record
{
"id": "49987c869dc29c39ebd4c5cf2f95f2953a690c820fd10d331618382f0d572114",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-9640",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-9640",
"summary": "A privilege escalation vulnerability exists in LXD from 6.0 before 6.9, 5.21.0 before 5.21.5, and 5.0.0 before 5.0.7 regarding the handling of project-restriction policies during snapshot restoration.. An authenticated project operator in a restricted multi-tenant environment can bypass policy restrictions by importing a maliciously crafted instance backup containing restricted configuration keys within a snapshot. When the snapshot is restored, these restricted keys are applied to the live instance without policy validation. Starting the modified instance grants the operator unauthorized host root access.",
"evidence": "osv:DEBIAN-CVE-2026-9640",
"products": [
{
"name": {
"value": "lxd",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "5.0.2+git20231211.1364ae4-1",
"evidence": "/affected/0/versions"
},
{
"value": "5.0.2+git20231211.1364ae4-2",
"evidence": "/affected/0/versions"
},
{
"value": "5.0.2+git20231211.1364ae4-3",
"evidence": "/affected/0/versions"
},
{
"value": "5.0.2+git20231211.1364ae4-4",
"evidence": "/affected/0/versions"
},
{
"value": "5.0.2+git20231211.1364ae4-5",
"evidence": "/affected/0/versions"
},
{
"value": "5.0.2+git20231211.1364ae4-6",
"evidence": "/affected/0/versions"
},
{
"value": "5.0.2+git20231211.1364ae4-7",
"evidence": "/affected/0/versions"
},
{
"value": "5.0.2+git20231211.1364ae4-8",
"evidence": "/affected/0/versions"
},
{
"value": "5.0.2+git20231211.1364ae4-9",
"evidence": "/affected/0/versions"
},
{
"value": "5.0.2-5",
"evidence": "/affected/0/versions"
},
{
"value": "5.0.2-5+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "5.0.2-5+deb12u2",
"evidence": "/affected/0/versions"
},
{
"value": "5.0.2-5+deb12u3",
"evidence": "/affected/0/versions"
},
{
"value": "5.0.2-5+deb12u4",
"evidence": "/affected/0/versions"
},
{
"value": "5.0.2-5+deb12u5",
"evidence": "/affected/0/versions"
},
{
"value": "5.0.2-5+deb12u6",
"evidence": "/affected/0/versions"
},
{
"value": "5.0.2-6",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "lxd",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.0.2+git20231211.1364ae4-9+deb13u7",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "5.0.2+git20231211.1364ae4-9",
"evidence": "/affected/1/versions"
},
{
"value": "5.0.2+git20231211.1364ae4-9+deb13u1",
"evidence": "/affected/1/versions"
},
{
"value": "5.0.2+git20231211.1364ae4-9+deb13u2",
"evidence": "/affected/1/versions"
},
{
"value": "5.0.2+git20231211.1364ae4-9+deb13u3",
"evidence": "/affected/1/versions"
},
{
"value": "5.0.2+git20231211.1364ae4-9+deb13u4",
"evidence": "/affected/1/versions"
},
{
"value": "5.0.2+git20231211.1364ae4-9+deb13u5",
"evidence": "/affected/1/versions"
},
{
"value": "5.0.2+git20231211.1364ae4-9+deb13u6",
"evidence": "/affected/1/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2026-9640",
"aliases": [
"DEBIAN-CVE-2026-9640"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "lxd",
"purl": "pkg:deb/debian/lxd?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"5.0.2+git20231211.1364ae4-1",
"5.0.2+git20231211.1364ae4-2",
"5.0.2+git20231211.1364ae4-3",
"5.0.2+git20231211.1364ae4-4",
"5.0.2+git20231211.1364ae4-5",
"5.0.2+git20231211.1364ae4-6",
"5.0.2+git20231211.1364ae4-7",
"5.0.2+git20231211.1364ae4-8",
"5.0.2+git20231211.1364ae4-9",
"5.0.2-5",
"5.0.2-5+deb12u1",
"5.0.2-5+deb12u2",
"5.0.2-5+deb12u3",
"5.0.2-5+deb12u4",
"5.0.2-5+deb12u5",
"5.0.2-5+deb12u6",
"5.0.2-6"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-9640.json"
},
"ecosystem_specific": {
"urgency": "end-of-life"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.0.2+git20231211.1364ae4-9+deb13u7"
}
]
}
],
"package": {
"name": "lxd",
"purl": "pkg:deb/debian/lxd?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"5.0.2+git20231211.1364ae4-9",
"5.0.2+git20231211.1364ae4-9+deb13u1",
"5.0.2+git20231211.1364ae4-9+deb13u2",
"5.0.2+git20231211.1364ae4-9+deb13u3",
"5.0.2+git20231211.1364ae4-9+deb13u4",
"5.0.2+git20231211.1364ae4-9+deb13u5",
"5.0.2+git20231211.1364ae4-9+deb13u6"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-9640.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T11:47:30.866448121Z",
"provider": "osv",
"upstream": [
"CVE-2026-9640"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-9640"
]
},
"related_cves": [
{
"value": "CVE-2026-9640",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 450832,
"published_at": "2026-06-26T16:16:37.25+00:00"
}