Underscore.js has unlimited recursion in _.flatten and _.isEqual, potential for DoS attack
Underscore.js is a utility-belt library for JavaScript. Prior to 1.13.8, the _.flatten and _.isEqual functions use recursion without a depth limit. Under very specific conditions, detailed below, an attacker could exploit this in a Denial of Service (DoS) attack by triggering a stack overflow. Untrusted input must be used to create a recursive datastructure, for example using JSON.parse, with no enforced depth limit. The datastructure thus created must be passed to _.flatten or _.isEqual. In the case of _.flatten, the vulnerability can only be exploited if it is possible for a remote client to prepare a datastructure that consists of arrays at all levels AND if no finite depth limit is passed as the second argument to _.flatten. In the case of _.isEqual, the vulnerability can only be exploited if there exists a code path in which two distinct datastructures that were submitted by the same remote client are compared using _.isEqual. For example, if a client submits data that are stored in a database, and the same client can later submit another datastructure that is then compared to the data that were saved in the database previously, OR if a client submits a single request, but its data are parsed twice, creating two non-identical but equivalent datastructures that are then compared. Exceptions originating from the call to _.flatten or _.isEqual, as a result of a stack overflow, are not being caught. This vulnerability is fixed in 1.13.8.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-27601
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 04:43 UTC · Revision 1
Source evidence
Underscore.js has unlimited recursion in _.flatten and _.isEqual, potential for DoS attack
core-osv · Original sourcePublished 3 Mar 2026, 22:38 UTC
Underscore.js is a utility-belt library for JavaScript. Prior to 1.13.8, the _.flatten and _.isEqual functions use recursion without a depth limit. Under very specific conditions, detailed below, an attacker could exploit this in a Denial of Service (DoS) attack by triggering a stack overflow. Untrusted input must be used to create a recursive datastructure, for example using JSON.parse, with no enforced depth limit. The datastructure thus created must be passed to _.flatten or _.isEqual. In the case of _.flatten, the vulnerability can only be exploited if it is possible for a remote client to prepare a datastructure that consists of arrays at all levels AND if no finite depth limit is passed as the second argument to _.flatten. In the case of _.isEqual, the vulnerability can only be exploited if there exists a code path in which two distinct datastructures that were submitted by the same remote client are compared using _.isEqual. For example, if a client submits data that are stored in a database, and the same client can later submit another datastructure that is then compared to the data that were saved in the database previously, OR if a client submits a single request, but its data are parsed twice, creating two non-identical but equivalent datastructures that are then compared. Exceptions originating from the call to _.flatten or _.isEqual, as a result of a stack overflow, are not being caught. This vulnerability is fixed in 1.13.8.
osv:CVE-2026-27601
Complete source record
{
"id": "78b1478a4deba3d5f59c8e61a03b86cc43c46411273b0601928e70cf68a081c9",
"url": "https://osv.dev/vulnerability/CVE-2026-27601",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Underscore.js has unlimited recursion in _.flatten and _.isEqual, potential for DoS attack",
"summary": "Underscore.js is a utility-belt library for JavaScript. Prior to 1.13.8, the _.flatten and _.isEqual functions use recursion without a depth limit. Under very specific conditions, detailed below, an attacker could exploit this in a Denial of Service (DoS) attack by triggering a stack overflow. Untrusted input must be used to create a recursive datastructure, for example using JSON.parse, with no enforced depth limit. The datastructure thus created must be passed to _.flatten or _.isEqual. In the case of _.flatten, the vulnerability can only be exploited if it is possible for a remote client to prepare a datastructure that consists of arrays at all levels AND if no finite depth limit is passed as the second argument to _.flatten. In the case of _.isEqual, the vulnerability can only be exploited if there exists a code path in which two distinct datastructures that were submitted by the same remote client are compared using _.isEqual. For example, if a client submits data that are stored in a database, and the same client can later submit another datastructure that is then compared to the data that were saved in the database previously, OR if a client submits a single request, but its data are parsed twice, creating two non-identical but equivalent datastructures that are then compared. Exceptions originating from the call to _.flatten or _.isEqual, as a result of a stack overflow, are not being caught. This vulnerability is fixed in 1.13.8.",
"evidence": "osv:CVE-2026-27601",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-27601",
"aliases": [
"CVE-2026-27601",
"GHSA-qpx9-hpmf-5gmw"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/jashkenas/underscore",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "9374840c22e348083d0d072f30dc980622523259"
},
{
"fixed": "411e222eb0ca5d570cc4f6315c02c05b830ed2b4"
},
{
"fixed": "a6e23ae9647461ec33ad9f92a2ecfc220eea0a84"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:underscorejs:underscore:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.13.8"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "411e222eb0ca5d570cc4f6315c02c05b830ed2b4"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "a6e23ae9647461ec33ad9f92a2ecfc220eea0a84"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"1.13.7",
"1.13.6",
"1.13.5",
"1.13.4",
"1.13.3",
"1.13.2",
"1.13.1",
"1.13.0",
"1.12.1",
"1.12.0",
"1.11.0",
"1.10.2",
"1.10.1",
"1.10.0",
"1.9.2",
"1.9.1",
"1.9.0",
"1.8.3",
"1.6.0",
"1.5.2",
"1.5.1",
"1.5.0",
"1.4.4",
"1.4.3",
"1.4.2",
"1.4.1",
"1.4.0",
"1.3.3",
"1.3.2",
"1.3.1",
"1.3.0",
"1.2.4",
"1.2.3",
"1.2.2",
"1.2.1",
"1.1.2",
"1.2.0",
"1.1.6",
"1.1.5",
"1.1.4",
"1.1.3",
"1.1.1",
"1.1.0",
"1.0.4",
"1.0.3",
"1.0.2",
"1.0.1",
"1.0.0",
"0.6.0",
"0.5.8",
"0.5.7",
"0.5.6",
"0.5.5",
"0.5.4",
"0.5.3",
"0.5.2",
"0.5.1",
"0.5.0",
"0.4.7",
"0.4.6",
"0.4.5",
"0.4.4",
"0.4.3",
"0.4.2",
"0.4.1",
"0.4.0",
"0.3.3",
"0.3.2",
"0.3.1",
"0.3.0",
"0.2.0",
"0.1.1",
"0.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-27601.json"
}
}
],
"modified": "2026-10-28T02:30:33.518101644Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/27xxx/CVE-2026-27601.json",
"https://github.com/jashkenas/underscore/security/advisories/GHSA-qpx9-hpmf-5gmw",
"https://nvd.nist.gov/vuln/detail/CVE-2026-27601",
"https://github.com/jashkenas/underscore/commit/411e222eb0ca5d570cc4f6315c02c05b830ed2b4",
"https://github.com/jashkenas/underscore/commit/a6e23ae9647461ec33ad9f92a2ecfc220eea0a84"
],
"provider_metadata": {
"cwe_ids": [
"CWE-770"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/27xxx/CVE-2026-27601.json"
}
},
"related_cves": [
{
"value": "CVE-2026-27601",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 500359,
"published_at": "2026-03-03T22:38:38.955+00:00"
}