Medium
Bazel leaks user credentials through the remote assets API
Type: advisorySources: OSV
A bad credential handling in the remote assets API for Bazel versions prior to 5.3.2 and 4.2.3 sends all user-provided credentials instead of only the required ones for the requests. We recommend upgrading to versions later than or equal to 5.3.2 or 4.2.3.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-3474
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 8 Nov 2026, 02:31 UTC · Revision 1
Source evidence
Bazel leaks user credentials through the remote assets API
core-osv · Original sourcePublished 26 Oct 2022, 00:00 UTC
A bad credential handling in the remote assets API for Bazel versions prior to 5.3.2 and 4.2.3 sends all user-provided credentials instead of only the required ones for the requests. We recommend upgrading to versions later than or equal to 5.3.2 or 4.2.3.
osv:CVE-2022-3474
Complete source record
{
"id": "7cb11cde0658962b451cee768a6e676b823172c0ed22463b304be36b42e00a70",
"url": "https://osv.dev/vulnerability/CVE-2022-3474",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Bazel leaks user credentials through the remote assets API",
"summary": "A bad credential handling in the remote assets API for Bazel versions prior to 5.3.2 and 4.2.3 sends all user-provided credentials instead of only the required ones for the requests. We recommend upgrading to versions later than or equal to 5.3.2 or 4.2.3.",
"evidence": "osv:CVE-2022-3474",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2022-3474",
"aliases": [
"CVE-2022-3474",
"GHSA-mxr8-q875-rhwq"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/bazelbuild/bazel",
"type": "GIT",
"events": [
{
"introduced": "41feb616ae18e21fdba3868e4c298b0b83012f10"
},
{
"fixed": "bc087f49584a6a60a5acb3612f6d714e315ab8b5"
},
{
"introduced": "6b33bdb1e22514304c0e35ce8e067f2175685245"
},
{
"fixed": "ad6d3d59ab6706999fe9e604f350bdcbfe501db2"
},
{
"introduced": "eea58d1afb57c32937d323c072f122e4ceeac686"
},
{
"fixed": "df2f77c2a8602d1b729b6802ba2bfcac3dc54402"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "5.0.0"
},
{
"fixed": "5.3.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.2.3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.7.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
}
],
"versions": [
"4.2.2",
"5.3.1",
"5.2.0",
"5.1.1",
"5.1.0",
"5.0.0",
"4.2.1",
"4.2.0",
"4.1.0",
"4.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-3474.json"
}
}
],
"modified": "2026-10-28T02:30:52.773512387Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/3xxx/CVE-2022-3474.json",
"https://github.com/bazelbuild/bazel/security/advisories/GHSA-mxr8-q875-rhwq",
"https://nvd.nist.gov/vuln/detail/CVE-2022-3474"
],
"provider_metadata": {
"cwe_ids": [
"CWE-522"
],
"cna_assigner": "Google",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/3xxx/CVE-2022-3474.json"
}
},
"related_cves": [
{
"value": "CVE-2022-3474",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 521810,
"published_at": "2022-10-26T00:00:00+00:00"
}